Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Reported] Lamia's Charm killed a troop but didn't get mana

Platform, device version and operating system: PC/Steam

Screenshot or image:

What you were expecting to happen, and what actually happened:
The opponent had two troops with only three health remaining. I cast Lamia which Charmed the bottom troop (Hobgoblin) who killed the troop above it (I forget, one of the horse looking ones). This should have given Lamia 8 mana, but she did not get any mana back.

How often does this happen? When did it begin happening?
Once. Killing with Charm earlier in the same match did refill mana.

Steps to make it happen again
I dunno. This occured in an Arena game.

1 Like

I have also just seen this, while in Arena. I then tried this in explore, and it’s also a problem. Lamia’s mana retrieval ability seems to be no longer working consistently. Sometimes it works, sometimes it doesn’t. Have tried:

  1. Cast from empowered vs 2nd/3rd cast.
  2. Killing another troop otherwise before the charm kill.
  3. Killing 2 troops at once.
  4. Damaging 1 troop and killing another.

I think it’s only when it charms the last enemy and kills the 3rd enemy that the mana doesn’t return.

I also saw this bug happen. About a week ago, I was playing Arena, and the AI’s Lamia charmed one of my troops, killing an adjacent troop. No mana gained. I’m on Xbox, if that helps.

I saw it happen today as well. It worked once and never worked again throughout the rest of the run.

It looks like it only happens if Lamia’s spell target is the 4th troop and the 3rd troop dies from the charm damage. I’ve made a bug report. Thank you

1 Like