[Reported] Kingdom power stuck at level 0

steam pc and win10

I returned to the game after a few years away, and all of the kingdoms that I had unlocked previously are stuck at 0 Power. The Power button section of the Kingdom menus shows Power 0 and no three-bubble completion tracker; if I click on the Power button, I receive the message “No tasks are available for this kingdom.
I sent a few requests to the support center yesterday and now the requests show solved but nothing changes to my account and I didn’t get any reply from anyone except for the auto reply e-mail. This is my last hope, if this problem cannot be solved I had to quit

Screenshot or image:

1 Like

Hey @lavialos

What was your ticket number, I am following this up for another player & I’ll grab your ticket and check if what you are experiencing is the same.

Jeto - Support Human :woman_mage:t2:

1 Like

I have sent 5 requests and the most recent one is [Request #109247]
we had the same issues, exactly. I even copy and paste his description because it is what I faced too.
Requests that show solved is #109279 and #109247
Thank you for your reply. I’ll be looking forward to further info.

1 Like

I have this exact same issue as well (on xbox). Reported in ticket number 108168.

Also have full game crashes after winning every battle, and more…

If you find a fix or hear from support, please let us know :slight_smile:

After the new update this morning (adding Umbral Nexus), all my power levels have been fixed. Hopefully it is the same for the rest of you as well.
THANKS DEVS! :smiley: