PS4 and Xbox One patches for Gems of War are now live!

Thanks for the continued feedback. The new patches are in their final stages of testing, so with any luck, we’ll have the next update out by next week. Appreciate everyone’s patience!

Without knowing what platform you’re playing on or other important details, this doesn’t help us narrow down the problem you’re experiencing. I’ve been playing on PS4 for weeks myself, and while I’ve experienced a few of the CE- crashes after mana upgrades, it hasn’t been crashing constantly. If you’d like for us to help you on a one-on-one basis, please visit us over at our official portal and submit a ticket where we can dig deeper into the problem you’re having.

This goes for anyone else too. We want to help as much as we are able to. :smile:

If you had looked at your own forums it was evident that this issue was common to several players. I even posted on there about it. It’s obvious it occurs on both platforms. I use thw the ps4 as stated several times in previous support posts. Sending you a ticket doesn’t fix it. The patch is dodgy and is the thing that needs fixing. You need to thoroughly test patches before you release them.

Thanks for the feedback, and we do understand that. QA does put everything through a full test cycle, but sometimes issues can appear in greater numbers once they hit a retail environment where thousands, hundreds of thousands, sometimes millions of people are playing your game. Something that may have only appeared once in test suddenly becomes multiplied across many players. Anyway, the next patch is going through its final stage of testing, and we should have something for our players next week. Stay tuned.

On Xbox, aside from errors mentioned I just had an issue where the game wouldn’t allow me to select troops for Arena. I had no choice but to restart the game. Upon doing so my arena is now locked and can’t be used at all and showing something peculiar…

Any idea how to proceed?

I just had the same problem a couple of hours ago! I’m not nearly as bummed about the (apparently) lost 1000 gold as I am about the prospect of not being able to play arena mode. :-/

Agreed. You would be unable to fulfill arena tasks as well, not to mention lose the souls and trophy bonuses for those sorts of tasks. Would love some feedback from support on this. This is the first game-breaking glitch I’ve encountered on XB1- for any game.

Update: when I went in today the game had given me a random group so the error appears to have resolved itself.

Have the same problem in the arena that is mentioned here. Problem started 2 days ago and still cant chose a team. Playing on PS4 and have even tried to reinstall the game, but it dident solve the problem. Any ideas how I can fix this?

The developer was doing some server work on Friday (final tests for the new patch!), which affected some users who happened to start Arena battles during that time. It should be fixed as of late Friday, but if even after closing the game / restarting your console you are still experiencing the problem (no troops, weird multi-mana card), please submit a ticket to us along with your Invite ID, and we’ll get you take care of. :smile:

Hey. I did the task “Increase your kingdom”, but i didn’t receive any gems or any rewards for it. I save the video of me doing it twice and still didn’t do it. I did it again few hours later and didn’t get anything still. Would I be able to get it when the patch out or Im out of luck on it? thanks. Im playing on the ps4.

A ticket I send and now I got a random team for the arena and can get in the fight again. Thanks a lot :smile:

Send us a ticket via and we can work through this with you. You should have received 3 gems instead of 30. I’m told 3 is the correct number, but the in-game text says 30. We can help you though!

Just wondering if anyone else is experiencing this… But during a battle, when the action gets going faster, you see a lot more stuttering of the animation and is no way smooth. (which in itself is a pain) But also, I’m getting a ghosting of battle images sometimes, which stays on screen until the match is completed? Like when something takes a hit, and you see the animation expand, but this is what stays on there ghosted, and is not always easy to see through. … So I was just wondering if others were getting this?

Also, as for the drop speeds, I don’t prefer the speed up version. Much rather prefer the older speed, and this in itself could be adding to the jitter because too much is trying to happen at once? Just a thought…


would be nice if the use of a banner and a different color kingdom worked as well

this is a really great game and was wondering will there be couch co-op for in home battles?