Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Not Gems of War] Legendary Quest -- Rampage Mecha broken

Platform, device version and operating system:
Samsung Galaxy S8+

What you were expecting to happen, and what actually happened:
Legendary Quest “Defeat I Empire Rampage Mecha” seems broken.

  1. I can’t request a new quest – the button is gone and I only have “Go” button.
  2. Tapping Go takes me to a (seems like) personal Mecha for an Amass.
  3. Starting Amass gives a 1 minute countdown. I can see it, but no one else can either see it or join it.
  4. While the cost states “-10”, it takes 5 energy from me.
  5. If I have under 20 energy, it won’t let me create an Amass. As soon as I get 20, I can start and it drops me to 15.
  6. When the Amass fails, my energy was not returned. I didn’t notice this, so I had tried 14 times while trying to get people to see it… thus losing 70 energy. Frustrating when I finally noticed I was out of energy because I encountered #5.

There doesn’t seem to be anyway to complete this quest and no way to replace the quest.
I expect to be able to do both.
There isn’t any guidance as to what has to happen if just creating Amass isn’t the correct action. So there is no way to know if I am doing anything right.

How often does this happen? When did it begin happening?
This began happening today (16 Jan 2020). It happens all the time. No success ever.

Steps to make it happen again
I assume to just get a Legendary quest for mecha again. It is still on my system for another 12 hours. After that, I don’t know.

2 Likes

I could be wrong, but I believe you have the wrong game @Hathawulf

…one of us does at least. I suppose during GW week anything is possible.

4 Likes

Definitely the wrong game. This is a forum for Gems of War. This game. Nothing in the post sounds like it belongs in it.

That said, the OP followed the template’s instructions better than quite a few actual GoW bug reports.

11 Likes

How’s the comments instructions in regards to bug report threads working out for ya?
I believe the first instruction for bug reports is to check the known issues list…


Which should have been their first hint that it’s the wrong game forums. :man_shrugging: