Need to start game twice on iPad


#1

Platform, device version and operating system:
iPad6 with iOS 11 & 12

What you were expecting to happen, and what actually happened:
Tapped game icon on “desktop.” Expected game to start. Instead it crashed to “desktop” just before reaching the panning backgrounds.
Game starts fine on second attempt.

How often does this happen? When did it begin happening?
This happens about once a day on the iPad. Certainly not every time I start the game, though. Started happening when I got my iPad6, roughly corresponding to version 4 launch.

Steps to make it happen again
Try to start the game.
Not sure if unloading the game from memory beforehand makes it more likely.


#2

Hey @Starlite thanks for letting us know about this.

Can you please try all the troubleshooting steps here to see if it stops happening and let me know how you go?


#3

This happens to me too. I usually just ignore it and wait for the second restart.


#4

Also started seeing this same thing on iPhone 7. The crash happens on the next launch after the app gets automatically evicted from memory due to me using browser/email/etc. The 2nd try always works.

Pretty minor inconvenience for me, but yeah crashing to home screen might not give newer players a good feeling.


#5

This is probably the same thing I was discussing in the other thread about iOS crashes. It’s been ongoing since an early 3.x version, started around the time the Unity client came out.


#6

I can say with certainty that force quitting the app does not resolve the issue. Sometimes after a force quit I still have the app crash the first time I try to restart it.

The other things the article suggests—power cycling my phone, performing a RAM flush that might require me to go through the initial tutorial and re-link my account, or deleting/reinstalling the app—are all things I am unwilling to do on a regular basis prior to opening the game to see if they reduce the frequency of startup crashes.


#7

In order to determine the cause of this issue all troubleshooting steps would need to be tried to rule out hardware issues as this doesn’t occur on all iOS devices for all players.

Please let me know how you go.

@SirCookie unfortunately what you’ve described is a hardware/OS issue. I’d definitely suggest making sure your OS is fully up to date and either exiting all other apps or at least not using memory heavy apps while playing the game. Some apps are actually deceptively heavy on your memory usage, ie. Discord.


#8

OK, so here’s what I’ve tried, all with no effect on the issue.

Let me reiterate, that the issue is the game sometimes crashes on launch the first time I start it, but it always starts successfully on a second try.

  1. Turned down graphics settings.
  2. Force closed the game – I do this frequently, at least once a day, anyway (because I’m used to PCs).
  3. As a rule, the only app I have running simultaneously is the Dark Horse comic book reader – everything else has been force closed. I will try force closing the Dark Horse app as well and see if that makes any difference.
  4. Turned the iPad off and on again. :slight_smile:
  5. Refreshed the memory, as instructed.
  6. Uninstalled and reinstalled the game. Note that the iPad appeared to remember my approval for the app and did not prompt me for my AppleID password. My “uninstall” was simply long-tapping the icon and then clicking the x and approving uninstall. I did not shutdown the device before redownloading from the app store (in case that could make some difference).
  7. Storage on the device is not an issue.

Note that this is a brand new iPad6 that I’ve had for about a month. There are less than a dozen extra apps installed, and the only big ones are Gems of War, Dark Horse Comics and Elder Scrolls Legends.

I would love to send you a log file if I could find one. :slight_smile:

Hope this helps progress the detective work.


#9

You may need to be a developer (of iOS apps in general, not GoW specifically), to have access to the tools that provide detailed reports about crashes:


#10

@Starlite thanks for trying all that, can you check to see if you have any crash logs? Instructions below :slight_smile:


#11

Oh my goodness. I had no clue the iPhone recorded crash reports that I could send you all. How often do you want them? One per person? A daily digest of these things? Weekly bundles?

Edit: lol. I just went to the game, and it crashed. But it generated a crash report about the event!


#12

Any particular place you want these crash logs sent?

I’m not good at reading these, but it looks like it’s a null pointer dereference. But obviously I don’t have call stack symbols so I can’t help past there.


#13

It would be great if you could send them through via support here if you are experiencing this issue.

I also have this problem on my iPhone 5S - though not always :thinking: - it’s a weird one that looks like it will need some more thorough investigation.

A few more questions:

  1. What type of internet connection are you using when this happens? (e.g WiFi/4G)
  2. When the game ‘crashes’, before opening the game again, if you open up the multitask option where you see all apps can you see Gems of War there?
  3. Before the game crashes (but fails to load), does your game center account log you in? I noticed when reloading my game after the crash game center connects through and logs me in correctly.
  4. Is Gems of War set to background app refresh - on - when this happens?
  5. Your OS version if you haven’t already mentioned it.

#14

Same thing here, started since the unity update on my iphone 6. Meanwhile I tried a few times to reinstall the app, relinked my account and even reinstalled the whole iPhone twice.
The problem persists during all the time.

It’s like SirCookie said, when the game is closed in background (or removed from memory), due to other activites
I tried to repdoduce it now, but now it works :-/, ok reproduced it…
But on wifi it works, on 4g, everytime I fill the memory with some other apps it failes at the first start.
In the multitask overview the game is loaded, but when I hit the task the game starts from the scratch.


#15

I’ve noticed your ticket, so we’ll follow-up with you there.

Thank you everyone, I’ve added the details to a report for QA.


#16

For everyone - please be clear if this happens when the game is already open in the background (and you launch it from the desktop of the device) or if you are opening Gems for the first time that gameplay session? (and it is not open in the background).


#17

Tried it a few times now, mostly when I override the session memory with other apps and just start it from tasker or desktop then the app crashes on this new session. But still not always!

When I override the session and remove the app from tasker, in four out of five times, the game starts normally, on my last (fifth) try, the app crashed again on first start :frowning:.

So sorry for not giving you a constant results.


#18

Just submitted my crash log via a help request. Hope it’s useful. Thanks.


#19

This happens to me frequently but always seems to be if the game was previously open and is therefore in the background. 2nd launch is always fine.


#20

Hi @rethanon

To confirm, you are also having an issue where Gems of War will close to the home screen of your IOS device if you select it from the home screen, and if it is left open in the background after using other Apps? If so:

  1. What type of internet connection are you using when this happens? (e.g WiFi/4G)
  2. Before the game crashes (but fails to load), does your game center account log you in?
  3. Is Gems of War set to background app refresh - (“On”) - when this happens?
  4. Please send your IOS version
  5. If this happens again and you’ve got the time it would be great if you could send through some crash logs to support using this link. For info on getting crash logs go here.