Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[More info needed] There's a Bug in Campaign- XboxOne Series S/X

I loaded up Campaign to do my Tasks and when the Banner Bearer task showed up, in Gold Task it had Bear Banner and Bonze Task had Vamper’s Banner. So i select Gold Task then selected Do Task “Be taken to best place to complete this task” AND Gems of War freezed up then just quit working so i tried the Bonze Task and samething happened, i did the same thing over and over so IT IS A BUG! Banner Bearer kicks me out of the game when i try to select Take me to best place to complete this task. Please fix this bug. Now i just tried to use the Do Task option on DeathKnight Hero in bronze and the game freezed up and liked me out! The only way i can safely complete these task is to go equip everything my self going to Troops & Teams. Every time the Do Task is used in Campaign it kicks people out of Gems of War completely and we all have to re start the game!

Hey, I’ve tested this and wasn’t able to reproduce the issue.

Can you please double check if you own the Banners/Hero Classthat these Tasks require?
If so, can you please tell me your invite code so I can check your account for any errors?

My invite code is ADAM_91 Version Number 5.5.1r27557 thank you for replying i double checked i have the Banner and Hero Class, when i hit Do Task on gold task 7/10 Chapter 5 Forest of Thorns Campaign it boots me out of gems of war game completely :slight_smile: