Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Keep losing connection

What you were expecting to happen, and what actually happened?
I keep receiving the Lost Connection error when I attempt to accomplish anything in-game. It occurs at different times. Not sure if this is just a local problem or not.

What are the steps to make it happen again?
Exit the game and log back in, same thing.

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post! Here is the latest. I had just won a PvP battle and got the error, in background, as the Victory shield dropped. Hope I get those PvP points…

The above screen is what I am receiving after every battle… still…

Quest or Pvp haven’t tried a challenge yet.

Anybody else experiencing this?

EDIT:
Yep… Challenges too, same screen. The Quest and Challenge show as beaten but I do not know if I have received any rewards for doing them… I do not believe that I have… :frowning:

What platform are you using?

Same here.

I use my Ipad to play this game.

Everything good before update. After update I lose connection everytime I win a battle

I am on PC, Steam.
As I said in my OP, it might be a local issue on my end…

Ok, so Im not alone! :wink:
I feel so much happier when there’s another sad person with me! :grin:

I’m on PC Steam. I just tested a casual PVP, and the victory screen was normal. So, I’m not sure what the issue is.

I just tried to open the app on my iphone, using the cell network, not the local wifi my PC is on and it wouldn’t even load my hero…

I think I have upset Rngesus… :worried: