[Fixed in 4.6] Game hangs with loading animation

Platform, device version and operating system:
Steam, Windows 7 x64

What you were expecting to happen, and what actually happened:
Since v4.5 came out, the game has hung on my PC twice. I don’t believe I ever saw it hang on PC prior to this patch.

While on the world map, the loading indicator starts up (cannot recall if it was before or after collecting tribute, or after exiting some other menu), and that’s how the game stays. Nothing at all can be done. The loading animation (row of gems, plus rotating colour wheel) just keeps running. The game has to be terminated from Task Manager.

How often does this happen? When did it begin happening?
Twice since v4.5 landed. So far.

Steps to make it happen again
I shouldn’t need to say this, but I suggest you look at the code added with v4.5, especially that associated with the loading animations. Given that there are occasional visual bugs associated with those animations, there’s a pretty good chance the programmer in question introduced other bugs. (The visual bugs involve uneven spacing between the gems in the loading animation, both between the start of one sequence and the end of the next, and between gems within the sequence. The shadowing of gems may also be unintentional.)

2 Likes

@Starlite

You should have provided the crash logs, if they exist, under Users/YourName/AppData/LocalLow/Pipeworks/GemsofWar/Crashes.
(Win 7 x64 - hidden files and folders must be enabled.)

Additionally, after you force closed the game, you should immediately copy the output_log file.
It contains important data that are overwritten each time you restart the game.

You can include the information here, but in such case, it’s best to contact the Support Team directly.
They helped me in the past with a pretty much similar problem.

Shadowing of the gems has been there for a long time. Sometimes symbols are distorted until they become normal, especially if you play for more than an hour or two.

Good luck!

P.S.: I haven’t had any crashes on my end. Win 7 (x64), PC.

1 Like

Can’t provide crash logs when the game didn’t crash. :slight_smile:

I’ll see if I can find the output_log file.

To be fair, I’m also so monumentally sick of reporting new bugs every single week – many of which are never ever fixed, or even acknowledged – that I’m unlikely to do more than the minimum. If the devs start pulling their weight, maybe I’ll return to fully-detailed bug reports. but for now, I’m totally burnt out on this nonsense.

As an example, the devs have refused to investigate the Critical Miss bug (where you get no mana after a gem match) on the ridiculous grounds that it’s not consistently reproducible. That’s like telling your mechanic you can hear a strange noise in your car, and them refusing to even look for the source. I expect that kind of thing from a mechanic who may not have finished high school (no offence); I expect a lot better from a well-educated software professional.

The output file is enough then.

The other option is to reinstall the game completely, delete even your Steam-cloud save (disable the check-box, but don’t forget your credentials. You’ll need to recover your profile.

I am aware about no mana gain bug, still, that doesn’t mean that the devs are refusing to fix it.

I would still push this. They helped me, even if it took longer than I had anticipated.

Let me know if they replied back to you, or if the Support actually did something to resolve your problem.

Thanks.

Just happened again.

I was exiting Guild Wars, after winning a match (yay!). The Guild panel-menu was dark (an old bug that hasn’t been explained or fixed), but when I went back to the map, the game got stuck on the loading animation. I was still getting chat pop-ups whenever someone posted, but I couldn’t do anything at all and had to force-close the game from Task Manager.

Here’s the log file:

Initialize engine version: 2018.3.7f1 (9e14d22a41bb)
GfxDevice: creating device client; threaded=1
Direct3D:
Version: Direct3D 11.0 [level 11.0]
Renderer: NVIDIA GeForce GTX 750 Ti (ID=0x1380)
Vendor: (null)
VRAM: 1984 MB
Driver: 24.21.13.9907
Begin MonoManager ReloadAssembly

  • Completed reload, in 0.227 seconds
    Initializing input.

Input initialized.

Initialized touch support.

UnloadTime: 0.905275 ms
DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.

(Filename: Line: 535)

DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.

(Filename: Line: 535)

WARNING: Shader Unsupported: ‘Standard (Specular setup)’ - Pass ‘META’ has no vertex shader
WARNING: Shader Unsupported: ‘Standard (Specular setup)’ - Pass ‘META’ has no vertex shader
WARNING: Shader Unsupported: ‘Transparent/Diffuse + Extra Alpha’ - Pass ‘Meta’ has no vertex shader
Unloading 6 Unused Serialized files (Serialized files now loaded: 0)
UnloadTime: 4.926726 ms
DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.

(Filename: Line: 535)

DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.

(Filename: Line: 535)

Unloading 10 unused Assets to reduce memory usage. Loaded Objects now: 56126.
Total: 94.255959 ms (FindLiveObjects: 2.374259 ms CreateObjectMapping: 5.815603 ms MarkObjects: 85.894077 ms DeleteObjects: 0.171402 ms)

Coroutine continue failure

(Filename: Line: 61)

Coroutine continue failure

(Filename: Line: 61)

Unloading 3 Unused Serialized files (Serialized files now loaded: 18)

Unloading 309 unused Assets to reduce memory usage. Loaded Objects now: 96108.
Total: 203.062837 ms (FindLiveObjects: 4.883720 ms CreateObjectMapping: 5.744753 ms MarkObjects: 192.081350 ms DeleteObjects: 0.352395 ms)

Uploading Crash Report
NullReferenceException
at (wrapper managed-to-native) UnityEngine.Component.get_transform(UnityEngine.Component)
at Avatar+d__85.MoveNext () [0x000ee] in :0
at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00027] in :0

(Filename: Line: 0)

Unloading 1 Unused Serialized files (Serialized files now loaded: 19)

Unloading 1215 unused Assets to reduce memory usage. Loaded Objects now: 97369.
Total: 227.013023 ms (FindLiveObjects: 8.330943 ms CreateObjectMapping: 8.735007 ms MarkObjects: 207.887464 ms DeleteObjects: 2.059300 ms)

Unloading 1 Unused Serialized files (Serialized files now loaded: 19)

Unloading 1268 unused Assets to reduce memory usage. Loaded Objects now: 97768.
Total: 223.501137 ms (FindLiveObjects: 8.745526 ms CreateObjectMapping: 8.940751 ms MarkObjects: 203.560026 ms DeleteObjects: 2.254215 ms)

Unloading 1 Unused Serialized files (Serialized files now loaded: 19)

Unloading 1755 unused Assets to reduce memory usage. Loaded Objects now: 98222.
Total: 228.355775 ms (FindLiveObjects: 8.815139 ms CreateObjectMapping: 9.348217 ms MarkObjects: 207.082122 ms DeleteObjects: 3.109678 ms)

Unloading 1 Unused Serialized files (Serialized files now loaded: 19)

Unloading 1917 unused Assets to reduce memory usage. Loaded Objects now: 98583.
Total: 234.486646 ms (FindLiveObjects: 8.675604 ms CreateObjectMapping: 9.561387 ms MarkObjects: 212.527385 ms DeleteObjects: 3.721652 ms)

Unloading 1 Unused Serialized files (Serialized files now loaded: 20)

Unloading 2281 unused Assets to reduce memory usage. Loaded Objects now: 98639.
Total: 240.964653 ms (FindLiveObjects: 8.760067 ms CreateObjectMapping: 8.810188 ms MarkObjects: 219.566006 ms DeleteObjects: 3.827463 ms)

Unloading 1 Unused Serialized files (Serialized files now loaded: 20)

Unloading 1377 unused Assets to reduce memory usage. Loaded Objects now: 91701.
Total: 227.534654 ms (FindLiveObjects: 7.899963 ms CreateObjectMapping: 8.703758 ms MarkObjects: 208.717557 ms DeleteObjects: 2.212757 ms)

NullReferenceException
at (wrapper managed-to-native) UnityEngine.Component.get_transform(UnityEngine.Component)
at Avatar+d__85.MoveNext () [0x000ee] in :0
at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00027] in :0

(Filename: Line: 0)

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
at TroopCollectionMenu+d__162.MoveNext () [0x0008b] in :0
at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00027] in :0

(Filename: Line: 0)

Uploading Crash Report
Setting up 2 worker threads for Enlighten.
Thread -> id: 1dc8 -> priority: 1
Thread -> id: 8a8 -> priority: 1

When I had this issue like yours, I have always created a private and public Support ticket.
Privately send logs were there for the Support to deal with this issue directly and much faster.

Sadly, posting it here probably somehow lowers the priority.