[Fixed in 4.3] Flame Soul +7 or more bug

Platform, device version and operating system:
PC, Windows 7

Screenshot or image:
10 sec video : https://youtu.be/kuAcw0RjEfc

What you were expecting to happen, and what actually happened:
I was expecting the game not to freeze :wink:

How often does this happen? When did it begin happening?
The bug is 100% reproductible and can happen in any game mode. It can also be triggered defensively but with a low odd though.

Steps to make it happen again
When casting The Flame Soul with an upgrade 7 or higher, if the selected gem (red) is destroyed due to the 7th upgrade which destroy 3 random red gems the game will freeze. You can reproduce the bug with 100% accuracy if there are only 3 red gems or less on the board.
This is very specific and I know @Kafka heard about it in the beginning of october without all the details but since this exploit is now used in GW defense teams (probably not on purpose though) it should be adressed.


Ahem… With all due respect i have doubts about that.

Hi @Ally

Thank you for your report, I’m sorry you encountered this issue :frowning:

I’ve made a report for QA to look into. We tested this issue before this update and couldn’t reproduce it so it seemed it was fixed.

Can you please send me your invite code + level + guild? Having trouble finding your account because the invite code on your profile is very much like another 3,000 people

Hi @Cyrup

Actually, the issue wasn’t encountered by me, but by one of my guildmates during the last Guild Wars, that’s why I looked into it and tried to reproduce what was producing it.

My invite code is ALLY , I guess I’m the real one :wink:, I’m level 1372 and part of the guild “Light Army”

I tried to reproduce the bug a couple of minutes ago and it is still there and you can easily reproduce it when there are few red gems on the board when casting the flame soul on one of them (100% chance of happening with 3 or less gems on board). Here is a screenshot showing the same issue as there was in the 10 seconds video :


Hi Ally, thanks for the additional information. Can you please PM me your guild mate’s invite code?

We’ve had two people test this and we can’t reproduce the issue yet so we’ll need to keep trying. Could you please find out for me:

  1. How long had the game been open for beforehand?
  2. Did this happen the first time you used the Weapon in the battle?
  3. What is the platform and operating system of the person who you reported this for?
  4. What game mode was played before hand?

Cyrup, this is a known bug to me but i was blaming the excessive lightning graphic at the end of a spell cast. I did 1 round of class event (today) with the spear equipped and i encountered 2 match crash events. I do have the spear fully traited. I agree with ALLY, my screen looked similiar when the board crashed as gem spaces appeared on the board. Ran a pvp match on 11/30 and crashed the board after casting FS.

Hi Cyrup, I don’t think my guild mate’s idendity is a secret so I can just write it there, it was FANG_HSJJ

  1. During the 1st tries, the client was open during a long time, but to check if this was influential or not I tried to reproduce the freeze the fastest possible and I succeeded in reproducing it 65 seconds after launching the client.
  2. Not necessarily, when I first tried to reproduce the bug, I let the defense team do it and it could take many many Flame Soul cast. Now, when I’m reproducing it myself, I cast the Flame Soul after wiping the red from the board (ideally 3 or less red gems remaining) so in this case, the freeze happen with the 1st cast of the Flame Soul
  3. Both I and the player who reported the bug to me were on PC, but the report of the same bug in early october by “tva” was on android.
  4. The bug was seen during a GW battle, during tests in practice battles and in explore. For practice battle and explore, I could trigger it with on the 1st battle after a client restart.

If I had to take a guess, I would say the problem is that the spell require a gem as a target and destroying this same gem (with the +7 perk) before the spell is totally resolved cause the freeze (can’t access the (X,Y).gemcolor).


I would be inclined to agree - that was my thought as well! Please don’t misunderstand my questions, it’s more to get a general picture of what is happening. We’ve tried to reproduce this using your exact scenario with that idea in mind and can’t, so even if this is the cause we might not have the exact conditions, or maybe it’s a similar issue - good to be sure.

So to confirm and summarise your case: The Flame Soul with +7 can freeze the game when it is cast on Red mana with 3 or less Gems (regardless of whether there is a Red enemy or not). This happens recently on Steam. It doesn’t matter how long the game was open for and occurs in Explore, practice battles and GW.

I’ve added this to the report for the issue and the team will continue investigating!

If anyone else is experiencing this (e.g. @Hanom) please let us know:

  1. What Troops, Traits, and status effects are on your team + the enemy team?
  2. Hero’s class, Talents and Traits?
  3. Were there any Red enemies on your team or the opposite team?
  4. What Mana color were you targeting? How many troops of that colour were there?
  5. How long had the game been open for beforehand?
  6. Did this happen the first time you used the Weapon?
  7. What game mode did you play before this battle?
  8. Platform and operating system

To be accurate, the bug occurs when a red gem is targeted and then destroyed by the +7 perk. This can also happen if there are more than 3 red gems, but the less red gems the easier for the targeted one to be destroyed.
There can be or not be a red opponent, in both case the bug will happen.
I didn’t use the weapon before, and since there were a similar bug report in early october I think the bug didn’t appear lately, but was here since the release of the weapon.
Yes, the time the client was open has no impact and the bug can appear in explore, practice and GW, other modes may also face it, but I didn’t try them.
Also, even if I think that the +7 perk is responsible, all my tests were done with the weapon at +10 since I can’t downgrade it.

Hi Ally, no worries, thank you for confirming this. As mentioned the bug didn’t necessarily happen when we were targeting red gems in the situation you described so we’ll have to keep trying. Thanks again for your help!

Still no fix for this bug? It still exists…match frozen. I keep trying to use this weapon and it just burns me everytime i touch it.

Hey @Hanom yes, unfortunately we’re still investigating it :frowning:
If possible we need videos of the issue from anyone experiencing it.

We’ve tried reproducing the issue using the screenshots sent but a video of it actually happening will provide us with much more information to test with.

Record a video or completely uninstall the game on your PC (enable hidden files and folders).
Make sure that you have your credentials written down or Steam sync enabled.

Still, list all the units that you were using, including your Hero, etc.
Same goes for the enemy team. I’ll see if I can spot the issue by replicating it on my end.

I confirm hanging the battle in such situation in Android version. I can watch troops and click “Retreat” in the “Settings” menu, but cannot continue fighting.

Hi @Kafka, there was actually a video in the 1st post, but I can provide more.

The 1st is a video taken in November 2018 showing it after the opponent cast (not the easiest to get as you can’t control the color he will chose). The video concern a practice battle and is truncated to last 15 seconds : https://youtu.be/6_7gEducB4A

The 2nd was taken today in explore, you’ll have the full explore battle in the video and with 3 red gems on board the bug had 100% of triggering : https://youtu.be/L5d3py-AmxE (the video is 30 seconds long)

The 3rd was taken today in PvP, you’ll have the whole battle and I cast with 6 red gems on board, but since the targeted gems was destroyed by the weapon upgrade the bug happened. The video last 45 seconds : https://youtu.be/buuvZ4dQ5n0

If you want some other videos with different game modes, different teams, another video format, the shoot of my whole desktop, a live stream or whatever, you’ll just have to say the word.

1 Like

Someone suggested I should record a slower animation speed video, so here is a 1X animation speed video of the bug happening in explore ==> https://youtu.be/ydTfcMoagFM (38 seconds video)

Hey thanks @Ally we were hoping for a 2nd video to confirm what we found in your video.

But it looks like we’ve found the problem and have a fix for it hopefully for the next update, I’ll let you know if we need more information.

Thank you everyone!!!


IM glad you found a fix, it also happened to me today

Not fixed for me, with the sunspear class set as my class and the +10 Flame Soul equipped, using the skill triggers the crash on mobile.