[Fixed & Compensated] Missing/wrong campaign rewards on Switch (again)

Platform, device version and operating system:
Switch

What you were expecting to happen, and what actually happened:
No Pet, No Weapon, No Troops for Elite Pass

We’re very sorry for this. It will be fixed within 48 hours.

I’ve made a Known Issue article here on the help center:

2 Likes

And there is no artefact bonus level 1…

For me the bonus works…

Maybe restartin the game will fix it

It’s ok! I forgot my rewards…

its ok, with the amount of glitched event we had on nintendo switch since january it doesnt bother as much anymore :sweat_smile: no offence

1 Like

Hey just an update:

We’ve fixed this in the Campaign so anyone who hadn’t earned those Rewards yet will now earn the correct ones.

For everyone who had already earned those Campaign levels before the fix went out today, we are still working on fixing up your items for you. I’ll update you again when that is done!

3 Likes

Hey folks,

Just a note that unfortunately fixing the incorrect rewards for players who already earned them is taking longer than we initially anticipated but we are still on the case and I will post an update when I have one both here and in the Known Issue article for this issue.

Thanks for your patience!

2 Likes

Another update!

Unfortunately (or fortunately, depending on how you’re looking at it) the weekend is upon us.
I spoke to the team though and we should be able to address the rewards early next week as long as there’s no technical hiccups :slight_smile:

Have a great weekend folks!

Hey Folks, the missing items were sent to those affected on Monday Aussie time.

Sorry for taking so long to get back to you here, I was wiped out with the flu so off work.

Sorry to hear you’ve been sick @Kafka. I hope you’re feeling better now.

3 Likes