(Fixed) After buying Tier IV, the player does not receive a weapon (Sea of Sorrow) fixed!


#21

Please move to Australia so you can be hired by IP2. This incompetence about not testing things before they come out is unreal.
Not to derail this bug report. But Lust’s charmed trait doesn’t work when she’s on defense. I haven’t made a bug report about it because why waste my time. When they don’t see the need to test things before they’re released.
(Mind you I lost a GW match today because I forgot that I that I can’t cast HC to end a match. Interestingly enough it didn’t count the first match as a retreat, it gave me 2k points but also didn’t count it as a win, but a loss).
My apologies for the off topic vent. I’m just sick and tired of preventable bugs happening each week.


#22

Same here. Cannot equip the new class weapon.


#23

Eh, when I look at the picture I don’t see incompetence. I’ve worked with incompetent devs before, and believe me what they write cannot ship. I am almost certain if we did manage to get Lyya hired, not much would change.

Rather than bore you with a page of how developers work, here’s an analogy. I look at the size of the features we’re getting, the size of the dev team, and the amount of time they spend on implementation. Someone, probably the developer, has tasked the dev team with creating babies in four months.

It is one of the truths of software development that you cannot make a baby in much less than nine months. If you try very hard, ten is a target you can hit. Four requires you to settle for “something less than a baby”.

Settling takes a lot of forms in software development. One of them is things like this happen. If you’re within days of the deadline for submission to hit your boss’s target, it’s hard to remember to go double-check you put a ReleaseDate property in World.json for the new class weapon. Your monitor’s already covered in post-it notes, some of them weeks obsolete because “check the post-it notes” gets in the way of meeting the deadline. Short-term.

Being competent doesn’t fix this. It just makes you feel worse when you figure out you forgot. But a fact devs struggle with is the human brain can’t juggle much more than 7 things in short-term memory, and making a baby in four months requires you to juggle about 18. Add other people to the team and it’s just… miserable. “Adding developers to a late project makes it later.”

When you join a team you chain yourself to the boss’s desire. I’ve felt for at least half a year the people at the wheel of the GoW team want bullet point lists of new features more than they want a polished game. I can wax philosophical about an artist’s vision, but at the end of the day you have to buy groceries so sometimes you don’t get to be the idealist.

So I’d rather keep Lyya on the outside. Gowdb is part of what made the game comprehensible to me, and whatever Lyya’s doing right now gives enough time to keep it up to date. Put Lyya on the inside, and things won’t change.


#24

*Checks own employment history.*


#25

I also do not have the new weapon. :frowning:

I’m not really anywhere near earning it yet, though. Win/win!


#26

Same here, weapon not showing


#27

@Ozball is probably using that old haunted toaster again…
8KuCGUY
Duuuuude, is there any electrodomestics in the office that doesn’t causes issues? Mixer as of late has been quite the hot topic too. :stuck_out_tongue_winking_eye:


#28

I’s said it before and I’s sayin’ it again: in my experience, issues like this aren’t about “incompetence”, they’re about pipeline and process management. Even great devs will inevitably release flaky content if their workflow isn’t well-organized.

I feel like the devs hit a certain point where the speed of feature development outpaced their ability to manage the work, hence the long string of “how didn’t that catch that?”-type bugs.


#29

What’s scarier than the ghost toaster and bread-message is that BOTH pieces of toast came from the same outlet.


#30

I’m not even sure we received the Trait Stones & every thing else our Gems Purchased… When things like this happen it calls a bit of suspicion to the whole… I hope this will be corrected & appropriate compensation is forwarded.


#31

I’m another one who bought Tier V but did not get the weapon. I really don’t have time to slog through 250 battles to get the weapon which is why I bought the weapon. So when will this bug get fixed? I wanted to use it with the Class event but obviously that’s not going to happen.


#32

Probably need to wait monday since they not working during weekend


#33

My goodness


#34

Are we going to be refunded for our gems…I mean if I went to Walmart and bought a desk then got around back to load it up and it wasn’t there it would be a refund or a fight :joy: ijs I paid for a weapon i shouldn’t have to wait to use it


#35

I assume this will all be worked out Monday but I feel compelled to state that I also have not received the weapon after purchasing that tier in the event store.


#36

Me too, i can’t find my new weapon,emmmmmmmmmmmmm


#37

I also do not receive the new weapon. Please repair it.


#38

Actually they’d offer to let you wait until one is restocked, generally. “Backordered” is the term. Generally they wouldn’t sell it to you, and uh… generally there isn’t a loading dock at a Wal-Mart. Maybe you have them confused with a different retailer.


#39

@Cyrup since i saw you were there, do you have infos about this issue?


#40

same problem