Endless Loading when Revenging Twice in a Row

What you were expecting to happen, and what actually happened?
Had some Revenges built up from the night before, played one as per normal, won obviously, then when I went in to Revenge a second time, the kingdom emblem became super imposed, and can cause an endless load-loop if you either;
A: Click the ‘Defend’ button.
or B: Exit out, and try to reenter the Revenge section.

What are the steps to make it happen again?
Have at least 2 Revenges stocked up, play one, attempt to play a second one.

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!

What device are you playing on?

I got this on Steam on my very first attempt to revenge.
I closed the program and restarted, and it worked fine.

Cheers, we’ll investigate what might be happening.

1 Like

I ran into this as well, playing on IPad Air w/iOS 9.2.

I’ve got this too, I’m on LG G2 (android)

Yep - seems to be in all versions.

We’re investigating, but it seems that if you drop back to the world map before the second REVENGE battle you can avoid the lock up

Correct, but if you click the revenge button after the first (witnessing the large emblems) and then return to the world map, you get this fun little glitch:

I’m also on Steam, but I inititally failed to mention because I figured it applied to all systems.
Good luck with the fix! Be sure to squash all them bugs.

Old topic, but I just found it. This happens to me too on an iPad 2. I always exit back to the main screen and then go back in for my second revenge. I don’t get the lock up Zelfore describes at the main screen.

Has this been fixed yet? I haven’t checked to see if I no longer have to exit.

This no longer happens to me on steam, but I’ve had it once or twice on iphone in the last few days.

The patch for this issue is pending approval by Apple right now. Unfortunately they’re out of the office until God knows when so it won’t get looked at until they get back despite the dev team submitting it before the blackout date… Oh well.

TL:DR fix is incoming for mobile.

1 Like

That is a positive situation, nonetheless. It’s much better when there’s a third party to blame

any update for time frame on the android version? would like to be able to play on my tablet as well as my pc.

Unfortunately not.

Will there be any update for android? It’s rather sad to have to go back to map and do some other action just in order to fight 2 times in a row. .

it happens on the phone. a tedious yet seems to work cure is to go into guild click around on some of the options chat is what i click or activity; then go back into pvp and finish up. It annoyed the hell outta me too had to keep closing and reopening it so i decided to play around with seeing if going into things would solve it and its worked thus far hope it helps. I don’t play on apple phone, so if there’s a fix out for apple they need to apply it to other smartphones as well.

There is not yet a fix on Apple, I’ve been waiting for it too. We must have patience, yes, precious.

A better and faster fix for this (until they correct the issue) is to exit the PVP screen after a revenge battle, click on the ‘Troop’ section from the main screen, then exit back to the PVP screen to perform another revenge without glitch. Works every time for me

1 Like

Same problem here using Android Kit Kat version. Can only go to world map and get back in

Playing on Steam is fine.
But this problem still persists on my Iphone.