Daily Tasks and unique gnome troops


#1

My 2nd slot daily task says “Win 5 battles using unique Gnome troops”. I have had this daily task for 4 days now. I don’t have any Gnome troops as I have not won enough vault keys to win gnome cards. Am I now down to only 3 daily tasks to complete until I get 3 gnomes? I am hoping this is not working as intended, and yes I have restarted the app. That fixed the boss/tower troops tasks that I cannot do either. Can this daily task not be changed after a day or so of me not doing the task?


#2

Sorry PS4 player here


#3

This has been reported in the known issues thread, but no fix yet. I’d suggest filing a support ticket to ask for that task to be replaced. One of my guildmates now has this in 2 of his 4 tasks…


#4

Nothing needs to be fixed. Treasure gnome. Pet gnome and Cedric…
They can’t help it if you don’t have all 3.
I have the task as well but it’ll change for tomorrow.


#5

No, it won’t change for tomorrow if it is in any but the first slot. Slots 2 through 4 only change when the task is completed.

The difficulty of acquiring all three of these troops makes accomplishing this task unreasonably difficult for all but a handful of players. Having two slots occupied by a task that can’t be completed is doubly unreasonable.


#6

Stan,
Thanks for the helpful advice and actually reading my post. If the 2nd slot task would change I wouldn’t have made this post.

Freestyle604


#7

@Stan is correct. One thing you can put in your request, below

(Explanation) Because DT are auto generated off all Race types and All Kingdoms minor problems pop up from time to time. The auto tasks has generally been very nice, compared to the old system. because the developers don’t need to constantly rember to edit the DT variable table when new things are released. Unfortunately by scraping the Troop Type they picked up “Boss” and now “Gnome”. Boss was added to an exclusion list, so on reboot it would refresh the DT.

Gnome needs to be added to this same list.
@Saltypatra


#8

I did a support ticket and bug report. I get it isn’t their fault I don’t have any gnomes. With the lack of vault keys I fear I will never get rid of this daily task. I just don’t understand why the task doesn’t go away the next day. Any chance someone from GoW can let know if this is working as intended? As when I get the boss or tower troop request a restart of the application gives me a new task. It has been almost a week now and I still haven’t won my first gnome from the vault. I normally get the 100 souls, 2 minor traitstones and various amounts of gold but that is a different topic.


#9

In the 3.4 Gnown issues thread, Cyrup said that they tried to fix it but it didn’t work. They are still trying to fix it and I’m hoping that today is the day. My guild is up to 4 people that have one or two of their tasks stuck with this and similarly have no realistic hope of getting the missing gnome troops they need to clear it.


#10

It took a ticket time of 4 days.


#11

I’m still waiting for a response on ticket. Day 7. Even though nothing will be fixed it just shows how backed up they are.


#12

Good to know I am not alone. Maybe they will reward us for our patience with the issue with some vault keys or gnome troop cards. LOL. I love the game, but daily tasks are normally an easy way to get additional resources every day. Just sucks I am down to 3 daily tasks.


#13

Just image hitting the jackpot with it taking all the slots!


#14

@Freestyle @Santandrix

Try restarting your games. Two people in my guild are reporting that their Gnome tasks reset!


#15

@Stan, sure enough it’s gone! I’ll take it!


#16

Now if we can get rid of this profile bug!!


#17

Do you mean the one where you can’t contact a person through in-game chat (to send invites and such)?


#18

Yes
I had 2 high level players join by open guild and they will not look at guild chat. They seem decent and I would love to put them in our group so they can know when pets are etc. Its aggravating and I hope they stay until it gets fixed.


#19

Yeah, that would be really annoying. Probably something to do with the Unity upgrade - hopefully gets fixed soon.


#20

Logged in and the gnome quest was gone. Finally, and thank you.