[Contact Support] Screen freezes on war bands intro

Platform, device version and operating system:
Android, Samsung A50, OS-10Q

Screenshot or image:

What you were expecting to happen, and what actually happened:
I earned enough of whatever reward buys warbands and the guy is trying to show me how to get war bands but the screen freezes with the green arrow pointing to the shop headers (with no war bands option). I reload, restart the phone, reinstall…same thing. It brings me back to the dude telling me I can now get war bands. I can’t x out of this screen, I don’t want the warbands, I can’t play…

How often does this happen? When did it begin happening?
First time with re-set at 2 AM when I earned the rewards, have been trying reload, restart, reinstall (nothing worked).

Steps to make it happen again
I did nothing. Just got the rewards that triggered the warbands and here I am.


I encountered a similar situation on Xbox, thinking I could just hit b or a and cancel Luther’s dialogue. Hitting LB to scroll over worked. I don’t know what the mobile equivalent of that is.

Hey @pugsviella this issue should be fixed for you now.
Please try force closing and re-opening the game and let me know how you go.

I am having the same issues. I cannot get past the Luther prompt. I’ve tried restarting the game multiple times to no avail. I am on Android as well. I do use an app that lets me play on two accounts, and the real cash transactions are not available in the game store when playing on my alt account. I am assuming it has something to do with that, as the warbands tab is not available while playing on that account. Any help with this issue is appreciated. Thanks.

Restarting the game did not work for me, but clearing the data/cache on the parrallel space app I use for multiple accounts did solve the issue. Just had to relog into the game with the account.

Will the warbands tab ever be available in the store for my alt account? Seeing how it is not tied to actual real cash purchase in the store, I don’t see why it wouldn’t be available. You only need the war coins to purchase these.


The problem keeps coming back. I get the prompt again after some activity. Also if I enter the store. So, I can no longer buy the weekly troops either now. Please help with the issue. We need a patch to get the Luther prompt to go away, or make it so war bands are purchasable in the shop for these instances.

No, it still won’t work. I also tried reinstalling the app with no change.

1 Like

I’m locked out as well. Devs will have to patch this it looks like.

Sorry to hear, but misery loves company. I was hoping it was bigger than me so it would be addressed.

Timing is everything…there were such good rewards for watching ads. I guessed it was only for holidays.

I was able to find a work around. If you can log into your account from a new device or steam account that has access to the full store (not through a multiple accounts app) you can clear the in game prompt, then go back to you old device. It’s not ideal, but still a way around it. Are you using a multiple accounts app as well? It has something to do with not being able to access the full shop with micro transactions. Maybe one of the devs around here can better explain it?

1 Like

Same issue on ps4 for a new player in my guild, frequently dragging the player back into the Luther tutorial after every match…

Any sign of a fix? @Kafka

I still can’t access the Shop without Luther popping up and freezing the game. At least now I can just restart the game to make him go away.

1 Like

Same for me on PS4

After the last update, the game stop to freeze but still I can’t see the warbands tab.

@naornoga have you tried reinstalling the game? And does this happen each time?

I reinstall the game but the tab is still missing (each time I log in).

This looks very strange, do you think it could be something to do with the PS Remote Play app? Have you reinstalled via this app, or on your PS itself?

I reinstalled the game from the PS4 itself.

Reinstalling doesn’t help with Android
Problem exist since the last update

After updating the game to the last version (5.4.0r26696) I discovered the bug still exists but now the freeze appears only when I’m entering the shop (PS4).