Playing mobile/App Androud

Every time I try to access the shop Luther appears telling me something about Kriegsmeuten and freezes the game. I can’t click on anything to continue

Happens for the first time just after the latest update and happens Every time I want to access the Shop

Looks like this issue:


Thank you
as my language is German I don’t know the correct english equivalent to search for

1 Like

Still not fixed

A workaround I can think of (assuming you play on phone or smth). Pick another device (bluestacks for example), and try there, might go right, and then back to your own device, but the tutorial will not come again

Thanks for reporting this, it’s been passed on to the team. (It’s worth reinstalling your game if you haven’t tried that yet.)

Related issue: [INVESTIGATING] Buying war band got me stuck

Common denominator is that they both don’t use English as game language, switching to English might possibly help to get past Luther.

Thanks.But I have to follow Luther’s instruction, so I cannot touch the SETUP button.

Looking a bit closer through the other linked topic it also seems to show up in English, so language settings are unlikely to help. The weird thing is that your shop seems to be missing some tabs, it should actually looks like this:


No “Gems”, no “Subscriptions”, and, most importantly, no “Warbands” tab in your shop, so Luther probably gets stuck trying to move you there. Beats me what could cause those tabs to go missing. Apparently reinstalling doesn’t help, so it’s possibly something server side in your account profile. Open a support ticket, maybe they can at least disable the tutorial for you so you can play again.

1 Like

Loading on this page goes on for a long time.

and then it jumps to the shop page above.

Once I open the game I can do nothing but follow Luther’s instruction.

Plot twist: Luther is the ultimate villain in the game.

1 Like

Sounds like it’s trying to load the initial shop content, eventually fails with a timeout and then jumps to some old layout page that confuses Luther. That page that loads a long time, what do the tabs near the top say?

Just as what you have said, “gems”,“subscriptions”, and so on; namely, that is the page supposed to be used by us.

Some possibly relevant information here:

A month ago I downloaded and played the game for the first time, and there was no bug. Two days ago I deleted the game, reinstalled it and played from beginning again (using the same google account), and then the bug happened.

There’s seven tabs on your page, I was wondering what the one not shown in the Warbands screenshot says.

The one between “weekly event” and “war bands” is “hornor rewards”. That is to buy items with hornor (wings won by PVP).

Can you send a screenshot of that page? Like @Fourdottwoone, I don’t have that 7th page, apparently a glory shop.

A while back (late last year I think?) the game shop was reorganized. I wonder if you have an old version.

Well, during the loading all the tags are disabled and after the loading the shop changes into this:

Now I have restarted the game and altered the language. Here is the shop:

Only after I collect 50 war coins and Luther asks me to buy a war band the the seven-tag page appears, but I will get stuck here, so I cannot show you what is in the tag.

This is the version number. I downloaded the game from Google Play, and the version is 5.4.0.

Bizarre. Well, good news, the devs prioritize monetization so this will likely be fixed in no time.

Until then, I really want to know what that seventh shop tab provides… :thinking: