Console 2.0.5 Known Issues

I’m doing the Glacial Peaks quest line. Freeze does not seem to be working correctly. It’s affecting troops on my team that are not frozen. Also, troops that are frozen are getting free turns.

My team power keeps changing on the pre battle screen but the team is the same.

I noticed this last night but forgot to post. Sometimes I would be in the correct place, sometimes in the 101-200, it switches back and forth at random.

2 Likes

I have a daily task (slot 1) to win 3 revenge battles. When I completed revenge battles in PVP, the counter did not advance. However, when I tried out explore mode (while completing a second task with 3 troops from Pridelands), the counter for both tasks advanced. There seems to be a problem recognizing when revenge wins are occurring. The other tasks seem to be working normally.

Same exact thing happened to me re: revenge counter not advancing for my slot 1 task, although I haven’t tried explore to get it to advance. I’ll have to mess with that when I get home.

@Sirrian @Nimhain ere is a new one. I have my 3 battles to choose from. I chose 1 and win. I get credit for said win. Then the same 3 battles come up. I choose new battle and win. Then error code comes up. Same 3 battles yet again. Chose different battle, win. Same error code comes up. Tried all 3 battles, tried exiting pvp and reentering. Still the same 3 battles. WTH?

Same set of battles.

That happened to me immediately after the update was released, but hasn’t occurred since. Have you tried exiting the game and re-opening it to see if that fixed the issue? I think that worked for me.

1 Like

Will try it out.

Bundles have vanished from the PS4 Shop section - “There is no content. It might not be for sale yet, or might no longer be for sale” popup followed by another “Sorry” message.

Edit they have now reappeared :smile:

Now I am getting the damn server error as soon as I enter pvp. Can do anything else but enter pvp apparently.

Haven’t seen that message before. Guess we will have to wait for the devs to chime in.

I still cant get on pvp :-1::-1::-1::-1::-1:

Weird, first 14 battles went off without a hitch. Then this. Seems I am dead in the water. Maybe I will just call it a night and try again tomorrow.

I expected some hiccups, but this is pretty bad. I play during the day on pc and it was bad there too.

We’re investigating the issues with PvP. It’s not happening to everyone, so we suspect there’s something gone wrong in specific accounts. We’ll keep you updated on any progress.

I am still seeing player class errors that were occurring in the last version of the game. I have prepared a video to detail the issue:

https://account.xbox.com/en-us/gameclip/70bc5aa0-ee5e-4587-b374-9cd55bf60efc?gamerTag=VegaDark541&scid=ed190100-58a8-4dd8-8019-8e8323a144b4

As you can see, when I go into the Orbweaver class, which is the current class I have my hero belonging to, it says “You will only gain the bonuses above if you change this to be your active class.” This is wrong. My class is already Orbweaver.

When I go into the Necromancer class, which is not my active class, it says “You gain these bonuses because this is your active class!”

This existed in the last version of the game, and I reported it. Hopefully this gets addressed this time around.

1 Like

Again, I was rolling fine until I hit the above issue.

1 Like

I had the same issue of getting the same teams, then getting the “battle already ended” error a few times, then pvp just completely stopped working for me also.

1 Like

I’ve decided I’ll wait until tomorrow and try again then.

3 Likes

Now the game won’t even load for me. Guess I’ll take the day off as well.

3 Likes