Can not promote/demote guild members Error screenshot attached


#1

What you were expecting to happen, and what actually happened?
Tried to promote a new member to hireling rank and got an error.

What are the steps to make it happen again?
I reloaded the game and tried to promote the same person again and got the same message. Reloaded a third time and tried to demote a different member as a test and got the same error message.

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!

Yes


#2

It’s looking like some kind of session conflict.
Are you running your account on more than one device?
Since the last update, GoW stopped allowing people to multi-box.
You can still play-switch between either your phone or your PC, but just make sure you don’t have them both turned on at the same time, otherwise weird , session-conflict stuff starts to happen.


#3

I have GoW on multiple devices but I’m currently only logged on on my pc. I don’t play multiple at the same time because I’m always worried about causing issues on my account.


#4

Thanks for reporting this bug. We’re deploying a fix for it right now, so hopefully it should work now.


#5

Ok thanks! It worked that time. :grin: