3.2 Known Issues (PC/Mobile/Console)


I’m still getting the download-files-when-you-log-in thing, it’s been happening since the last big update. At least one other guild member is also having this issue. Lucky for me I’ve got an unlimited data plan! :face_with_raised_eyebrow:

The defense teams resetting bug is MUCH more concerning. I’ve had this happen a couple of times and it is maddening! So far this week my defense teams have been sticking ( :crossed_fingers: ) but my GM has been plagued by this every day this week! She’s doing all the little magic tricks everyone advises (change name of team after adding it to defense list, etc) with no effect.

This is a really terrible bug not just because it’s costing us GW points, it totally negates the one really good addition from the UI update. Please prioritize fixing this one!

Also, the new UI is still rather ugly. :wink:


Yeah I still get the download assets thing to click every time I log in.


Every time I log into the app I have to download 2.19MB of assets.


Word from my guild mate is that “The PC version is unplayable if you have a controller plugged in”.

Can anyone else confirm this?


The background vanished. It happened when I accidently clicked on a kingdom then I clicked on chest menu without waiting for to load the kingdom menus/assets. After that all of the background assets didn’t render anymore only when I restarted the game. (PC)


I tried that, and I can play the PC version with controller and mouse at the same time. (If I’m using controller the mouse cursor disappears and the controller button hints appear, but if move my mouse then the cursor appears and the controller button hints disappears.)


I don’t know what it is, but on PC + controller I can’t get to the bonus menu, only if I move the mouse over it.
If I switch back to controller, then I can’t move back from the bonus menu.


Here, I confirm it’s playable with controller and mouse on PC.


Thanks. I’ll ask for more specifics from them.


Just to further what AnarchyChampion’s posts, yes, the PC version does support controllers as well as Mouse. The game should automatically detect what control scheme was used last, and change the UI accordingly. As the PC/Mobile version and the Console versions have been synced, PC (and technically Mobile with controllers, although not officially tested) will also work. Just ensure that no buttons or analog sticks are in an “ON” state (e.g. Analog Stick not exactly in center), otherwise it will attempt to swap between controller and mouse continuously.


I’ll pass this along and see if that resolves the situation.


My pvp battle didn’t give my trophies, glory, event gems or pvp points and the gold is wrong too


Any update on when you will fix the basic mechanics of setting and keeping a GW defence?

It still doesn’t work reliably (on iPhone at least).



Every time I start the game I have to download either 2.19MB or 18.65MB of assets.


Not receiving traitstones on Explore fights…


Cheers, we’re aware of the issue and are currently looking into it.


What’s going to happen to the people who used event keys in a desperate attempt to get infernus yet the pulled out abynissia instead? One of my guildies had that and one of the guys in my old guild too.


On xbox i just got a triple kill with scorpius,
It killed the 2 last troops but first troop was poisoned so he decided to kill it also lol


I posted a similar video Ricky. He wiped the whole team in mine!


Answer to GW defense reset bug.