3.2 Known Issues (PC/Mobile/Console)


Hold on, I’m not done. This game is broken and continually regressing.

I won against the paragon in GW with 2 troops left and was given a loss:


What is your point total for the day? It could be a display bug only.


Only 7459 including the unique defense troops, so I’m missing the points.


Best I can offer is to contact support. Unfortunately they can’t reimburse the points and mark it as win last I heard anyway.


Same issue.


My guild chest is 4 star but when i open guild chest there are still common troops instead of lowest troop is rare. I play in android phone


If the Common troops are one of the Guild Guardians then this is expected. Regardless of Chest level, 50% of your Guild Chest troops will be Guardians until you have them all ascended to Mythic with 4 or more copies each, at which point they’ll stop dropping from Guild Chests.

Edit: Added the “4+ copies” modifier. Thanks for the reminder, @Grundulum.


That means i have to ascend all common troops to mystic,right? Anyway thanks for your response.


Just those six Guardians: Honor, Courage, etc. And you need to go beyond Mythic to have them disappear. You must have all six at Mythic, with four copies of each, before they stop appearing in chests.


Every time I start the app I have to download approximately 6 assets totaling ~18.25 MB.


Known issue, and should be fixed in the next update. (They know exactly how to do it because they fixed it in 3.0 or 3.1 before re-introducing the behavior in 3.2.)

Does your device actually download 18MB of files, though? My iPhone threatens to, but then actually only downloads 2.19MB.


How am I supposed to know? It downloads things while the dialog is up. Sometimes I get all the way to the map with the dialog still on the screen. It’s been doing this in 3.0 and 3.1, 3.2 didn’t change it. So I’m not confident there’s a “fix”, which is why I’ve been mentioning it with increasing frequency.

I mean my game still doesn’t reliably “download images” or “display monster names”, forgive my lack of confidence. I hear “delete and reinstall” fixes the “doesn’t download images” bug, but can you blame me for doubting “You can restore your account with no snags”?


Thank you for taking the time to explain this.

I am still a bit baffled by the change in numbers for the Hourly Tribute screen now.

It’s easier at the lower levels to see the break outs, but my 1085 level account - the screen rushes through and I’m seeing much lower numbers than I was before that screen (which again thanks dev for putting it in).

I was tracking when the amounts were not showing correctly and I’ve been tracking since 3.1 when I noticed at least 12% to 20% drop in number of kingdoms sending tribute and a 25% decrease in gold as well overall.

I will see if I can’t gather some datapoints


When I disconnect from global chat it still shows on the map


I had that happen last week, and I tried to tell folks that I wasn’t behind, that I was disconnected from Global Chat, and was seeing clearly a different chat space.


When you kill a troop with Lion and Tiger, it will stun the next troop. I’m guessing this is the same problem as with Khorvash and others, where the secondary effect gets applied to the next troop if the damage portion kills a target?

@Sirrian wouldn’t the weapon work better if it stunned first anyway, with troops like The Dragon Soul around?


What would be the stats on that Troop…

PC Platform


In ranked PvP matches this has been happening more frequently lately where I win the match but it counts as a loss when the rewards are shown right after.

It seems to occur when I play certain opponents so it’s not random exactly. So if I play playerA and I lose even though I won, each time he comes up again the same thing happens when I win.

Really frustrating especially when you win a match from the 3rd column and you lose out on the rewards.


Lately I can’t enter some Explore modes in some Kingdoms. I wanted to farm Tratistones in Zaejin and Pridelands, and both can’t load and the window with error message pops out. I play on PC.


Every time I start the app I have to download exactly 2.19MB of assets. Every. Time.