3.0.5 Known Issues (PC/Mobile)

Noticed this earlier, but wasn’t able to post before:

Something is definitely very wrong with the end of battle screen souls count. Necromancy trait seems to be working as expected during battle, but the final number doesn’t make any sense.

I think this may have started with 3.0.5, but maybe it was broken earlier than that.

In every test I did, not only was the end of battle souls number incorrect compared to past results and my expectations, I could not figure out any way to make the math work out to the result on the screen. However, it wasn’t random. Given the same input of Necromancy traits, troop survival, number of enemy troops killed, and bonus souls earned, the result was the same. But the effective multiplier between the in-battle souls counter and the end result counter was not consistent across different inputs.

Here’s a list of ratios I’ve seen (first number is the count during battle, and the second number is at the victory/defeat screen), with death knight armor (100%), 45% from guild sentinel:

Max difficulty (+125%), 2/2 necro troops surviving (expected ratio 3.7x)
8 -> 33 (4.125x)
30 -> 130 (4.33x)
52 -> 218 (4.2x)

Base difficulty (+0%), 2/2 necro troops surviving (expected ratio 2.45x):
8 -> 22 (2.75x)
52 -> 145 (2.79x)
74 -> 196 (2.65x)

Base difficulty (+0%), 1/2 necro trait troops surviving (expected ratio 2.45x):
30 -> 56 (1.87x)
52 -> 96 (1.85x)
80 -> 176 (2.2x)

Base difficulty (+0%), 0/2 necro trait troops surviving (expected ratio 2.45x):
44 -> 54 (1.23x)
74 -> 91 (1.23x)

Base difficulty (+0%), 1/1 necro trait troops surviving (expected ratio 2.45x):
55 -> 135 (2.45x) - as expected

Base difficulty (+0%), 0/1 necro trait troops surviving (expected ratio 2.45x):
22 -> 37 (1.68x)
54 -> 88 (1.63x)

Base difficulty (+0%), no necro trait troops (expected ratio 2.45x):
40 -> 98 (2.45x) - as expected

I’ve tried every which way to tweak the formula to make it work out, but I can’t find a pattern. It’s so strange…

Aww, i hope you will change your mind.
i dont see any necessity in giving more mana to the gem spammers when they flood the boars with 4+ matches

its just one more nail to the coffin of not-fun aspect of console gameplay, i think

if you summarise it:

-explode more mana
-4+ more mana
-more mana from spawned gems not overwriting each other
-more cascades
-better ai choices

it sure does look like much more mana = not so much fun

2 Likes

Running some tests of my own, though will take a little bit. Just checking, do you have any VIP levels? And is 240% what it says below your hero on the world map?

The fact that it matters whether or not a necro troop survives to the end should in and of itself be classed as a bug. It was like this a brief time on PC/Mobile after necromancy was changed before being very deliberately changed to where surviving necro troops didn’t matter, only starting necro troops did. I’ve seen scattered reports of incorrect soul counts multiple times from in console specific threads, guess it never got fixed.

As for what I think is going on here, I’m thinking necromancy stacks additively with itself for the counter display and multiplicatively when considered after battle. They also appear to be rounding at every step.

For example:
Max difficulty (+125%), 2/2 necro troops surviving (expected ratio 3.7x)
8 displayed = 4 souls base generated (kills only)
4 * 1.5 = 6 (first necro activates)
6 * 1.5 = 9 (second necro activates)
9 * 3.7 = 33.3 (post battle bonus - rounded down)

30 displayed = 15 souls base generated, 2x necro
15 * 1.5 = 22.5 (rounded up)
23 * 1.5 = 34.5 (rounded up)
35 * 3.7 = 129.5 (rounded up)

52 displayed = 26 souls generated base, 2x necro
26 * 1.5 = 39
39 * 1.5 = 58.5 (rounded up)
56 * 3.7 = 218.3 (rounded down)

Base difficulty (+0%), 1/2 necro trait troops surviving (expected ratio 2.45x):
30 = 15 base souls generated
15 * 1.5 = 22.5 (rounded up)
23 * 2.45 = 56.35 (rounded down)

Didn’t bother doing the rest, but this seems to be what is happening.

For consistency’s (and simplicity’s) sake, it should be moved back to Necromancy being a pre-battle trigger and have the number on the counter in battle times your combined difficulty/armor/VIP multiplier is the number of souls you earn.

2 Likes

Edit: Nothing to see here. Posted a UI request in this thread because I didn’t realize there was a separate thread for that.

Hello @Svaldan this thread is for bugs and issues. Please discuss UI requests here.

Oops, sorry, will add my comment there :blush:

Mobile crashed today when I was doing GW, black screen, so I lost a match. Sony Xperia Compact Z1. Holy God and the Divines HOW ANNOYPHNG

1 Like

anyone else getting lower amount of tributes since this so called “update” or just me?

Another bug: I ascended a card (hit mouse button to the left then to the right) and all the buttons disappeared, then I hit Esc. Then the whole screen went black. Had to force quit the game (Alt + F4).

Please give us the OLD GoW BACK

Well, It is not only you. I have been collecting data for 4 days and I can say that in my case I am receiving tribute from less kingdoms.
I did similar check few weeks ago (at the time when I received tribute from 14 kingdoms) and the average was tribute from 8 kingdoms (average from 48 collections).
The average from last 4 days is 6 (35 collections).
I know it is not a huge sample but stil…

2 Likes

I’m not sure if this has already been addressed; I scanned through this thread and didn’t see it, might have missed it but…

(PC) I don’t know if it’s any spell that reorders troops, but I’ve got a Dust Devil in right now, and in a number of games now, enemy troops aren’t reordering when I cast Dervish, but the game still somehow thinks they have. So, when I match skulls, I’ll attack the second enemy troop. If I try to use a spell that allows you to choose the target, it’ll cast the spell on a different troop. Which makes end game a little tough (or impossible, if I end up losing the devil) because the enemy will only have (what looks like) the second troop left but if I target it with a spell, it’ll cast to an empty slot and nothing happens. And I can’t target an empty slot in hopes of hitting the phantom enemy card that I can actually see in the second slot. Just gotta with for the right skulls to fall and hope the enemy doesn’t get enough mana to cast on me.

May have made that a bit wordy, sorry.

3 Likes

Having 2 Kraken on my team and one gets entangled. Match-4s and 5s only deal 4 damage to all enemies now instead of 6 (=2*3). Havent tested with single Kraken but it appears that the dmg on match-4s and 5s gets reduced to 1 when Kraken is entangled. Not sure if it was like that before 3.0.5. or working as intended (which would be odd).

@saltypatra?

I don’t have any bonus to souls from VIP levels. 245% is what the screen says when I haven’t increased the difficulty (annoying that I have to actually fight a battle now to change that, btw).

Brilliant! That explains it perfectly.

Definitely bugged, then, with the various displays being inconsistent with each other. If that math is intentional, fine, but the battle counter ought to be fixed, then.

Also, I meant to check but haven’t yet as far as how many souls you actually receive to your collection.

EDIT: Yep, confirmed that you actually get what’s on the end screen.

I also just determined that the max you can get is based on additive necro traits, not multiplicative.

Playing with 3 necro traits, I could get 245 regardless of whether I generated 80 or 100 in battle.

As long as none of the troops with necromancy traits dies at the end, it does not matter if you got 80 or 100 souls, the payout is the same.

Now if one of them dies and you have 80 souls collected, then the payout is lower. But if you collected 100 souls and one or all of them died, you will still get the max payout.

Hope this does not get fixed as players can save some time farming souls.:blush::blush:

Yeah but unfortunately if you’re just clicking the right arrow to get to the number it doesn’t stop when you get to the max, it wraps around and you’re back at 1 again.

Amount filter not working correctly. Mouse clicking is all messed up, have to click a few times on buttons for them to work even though I see the button moving when clicked. Mouse sometimes moves gems the wrong way on 4X speed.

*facepalm.

If that happens, use the left arrow to go all the way back to the max.