Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Reported] Shahbanu spell graphic missing

On Android and iPad, for me and some in my guild, Shahbanu’s spell graphic is the generic hurricane-like placeholder and not the 3 genie lamps. BTW I love how fun the troop is to use.

What do you think it’s supposed to be? This is the only spell graphic I’ve seen for this troop.

The preview is here: https://gemsofwar.com/a-new-mythic-approaches-shahbanu-vespera/

And the image is 3 genie lamps like this picture:

1 Like


1 Like

Mine is the generic hurricane placeholder, too, on Android (can’t remember what it looked like on Steam).

Could it be related to having her fully traited (I haven’t decided on her third trait just yet)?

No troop has ever worked this way, it’s probably some kind of asset error.

1 Like

I’m not worried about it, I just wanted the devs to know. I went ahead and traited her, restarted, and did another “download all assets”, and it’s still not there yet.

On Steam, I have the correct lamps image, but on Android I have the hurricane.

1 Like

Thanks I’ve made a bug report for the team.

1 Like

Hi @Kafka there is a new wrinkle in this Shahbanu issue. I use the same account on Steam, iPad, and Android. The Shahbanu spell graphic is missing on Android and iPad but when I log into Steam, everything is good. On top of all that, the new troop Black Bjorn is totally glitched. The troop card is literally gray lines that constantly move to the left. And the spell card image is a black & white version of the weapon card ‘Riftblade’. Again, on Steam it’s all good but not on Android and iPad. I have no answers, I just wanted you all to be aware. And I do have one clue: I remember the notice ‘some assets failed to download’ on the Shahbanu release. I got the same notice again this week, when Bjorn was released. Ok that’s all. These are cosmetic issues and do not affect gameplay.

I checked this today and it was fine for me.

Can you both please try connecting to wifi on whatever mobile devices are having this issue and going to the game settings and select Download All Assets?

That should solve it.

I went ahead and tried that. I play almost exclusively on WiFi, and I’ve tried downloading all assets probably 4-5 times a week since the Shahbanu thing. It keeps saying, and it said just now, that there are no additional assets to download.

What devices do you have?

I’m using an iPad Pro 9.7 and a Moto G5 plus. The Moto G5 is running Android 8.1.0 (Oreo)

[SOLVED] I went ahead and uninstalled the whole game. When I reinstalled it, all troops were loaded properly. I will just do this the next time it happens, but I appreciate the help and also knowing others were affected. Thanks!

1 Like

@kris11 does reinstalling work for you too?

I had the same graphical issues on Android. I cleared the game data and cache, re-downloaded the graphical assets (400+ MB) and everything is fixed now.

Note if you do this, make sure you know your GOW account details as you will need to re-enter them.

Cards affected were:
Black Bjorn
Shahbanu Vespera
Fist of Zorn
One other that I forget. May have been a Satyr.

1 Like

Issue is still here guys, on mobile devices. When I start the game on Steam, the correct 3 lamps graphic is displayed.
When I play on my phone (Android S8+), the Hurricane graphic is still there for Shahbanu Vespera. Same goes for several of my guildies who just checked.

What’s worst now, with the release of Mistralus, is that it basically has the same graphic (the Hurricane) like Shahbanu on mobile devices…

This is on Steam:

This in my phone:

Aaaaand, this is Mistralus:

This was reported when she first came out months ago.

Its persisted through several updates. Restarting, checking wifi and all that nonsense is not going to fix it…

1 Like

I’ll ask the team to check this hasn’t resurfaced or remained in some of our assets. Thanks for including your device model that will help us find the issue.

Can you please try reinstalling the game to see if that forces the correct Vespera spell image to download?

(btw, Mistralus’ spell image is correct in your screenshot)

1 Like