[Reported] Missing "Spoils of War" offer in the Shop

Platform, device version and operating system:

Screenshot or image:

What you were expecting to happen, and what actually happened:
Expecting to see the “Spoils of War” offer in the Resources tab in the shop. “Spoils of War” offer is missing as you can see in the attached pic.

How often does this happen? When did it begin happening?
This is the first time I have seen this issue. Happening since Monday 20th Jun Reset.

Steps to make it happen again
Click on “Shop” then the “Resources” tab which shows the “Spoils of War” offer missing.


Thank you for bringing this to our attention! I have reported this to the Development Team for them to investigate this issue further.

Thanks again :slight_smile:

OminousGMan - Support Human :male_detective:

1 Like

It always disappears once I’ve bought it

1 Like

Yes i know it disappears once you have bought it but i never need. I went to go buy it and it wasn’t there.

Not sure if this will be any usefull, but:

on mobile, if i’m logged in, during weekly reset → most of the things don’t reload properly… (new troops/weapons graphics, weekly offers etc.). Only thing that helps is closing the game (killing the running process on android not tapping out to other application).

So my wild guess is: have you tried restarting the game on console? (not sure how gems operate on that platform, haven’t played on it at all)

Totally agree with things not appearing on reset if you have the game open so i always close the game around 1 min before reset and open the game again after reset.

It just wasn’t there this time and it is still not there. I don’t think it is fair that i miss out on that offer so will be interesting if that fix it for me because i still have heard nothing. @OminousGMan


I can jump in here for this quickly.
We are just waiting to hear back from the development team and as soon as we do, one of us will be able to get an update out to anyone with a ticket/in this thread.

1 Like

Ok no problems thanks @Jeto