Loading Issues on iOS and Android


#1

Hello, Adventurers!

THIS IS FIXED WITH A HOT-FIX UPDATE. TO RESOLVE BATTLE LOADING ISSUES PLEASE DOWNLOAD THE NEW UPDATE FROM THE APP STORE.

Go here to update on IOS

Go here to update on Android

Our 3.4 update has released today with all the Pets, BUT there is a loading issue for some players on iOS and Android devices
Read on below for more information and a temporary workaround!
And if you’re looking for any information on other issues, we have a known issue thread here: https://community.gemsofwar.com/t/3-4-known-issues-pc-mobile-console

1. What’s happening?
Some players on iOS and Android have been getting stuck in load screens. This is usually (but not always) when entering a battle.

2. How many people are affected?
Currently the issue is only on iOS and Android, as those players need to download the content of the game as they play.
It is affecting a significant number of people - it’s hard to tell more exactly than that, because the update has only just released.

3. Why is it happening?
In version 3.4 we’ve updated the Unity Engine to a newer version. This is necessary so we can support all the latest features of the various platforms on which we support Gems of War. Unfortunately, whenever we update Unity, we also need to update these things called “Asset Bundles” which contain all the art and audio for mobile devices. And when we update those, you guys need to download them all again. Something is going wrong with the downloading, and we’re not sure exactly what it is yet.

4. How can I fix it?
If you’re encountering this issue on iOS/Android, you can download the latest fix from the App Store (Google Play or Apple App Stores). We have released a hot-fix that resolves this problem. Go here to update on Android, and
Go here to update on IOS.

If this does not work, we’ve seen it fixed by removing the game from your device completely, and then reinstalling the game from your app store.
Your first battle will still take a long time to load, as it needs to grab all the audio files, but it DOES get into the battle eventually.
VERY IMPORTANT: If you’re uninstalling and reinstalling the game, please make sure to link your account first, and get a password!
Details on that can be found here:

5. What are you guys at Infinity Plus Two doing about it?!?!
The team is currently investigating exactly what the problem is… we’ll keep you posted when we know more.
We’re also investigating whether we can get an emergency fix out through Apple & Google as soon as we have one.

Once again, we apologize for this inconvenience, but just wanted to let you know we’re working hard to get a resolution as soon as possible.

[Edited by Sirrian from Salty’s original post to update more information about this incident]


Please help, pvp will not load since ive downloaded the new patch note
3.4 - Enough is Enough
#2

I’ve given up trying to play PVP after staring at the loading screen for minutes at a time, at which point I get fed up and exit. Every time.

Are you saying I just need to wait even longer, or is this something different?

(iOS)


#3

You will likely need to wait longer.


#4

like always wait longer, or just until assets are stored on phone, and then it will speed up??


#5

Well OK then. Nineteen minutes and counting. Just going to gently say that this is completely, utterly beyond what anyone should expect to deal with to play a game.

Having “patience as I play” would require actually being able to play. But this isn’t a bug, it’s expected?

I’m going to look for something else to play. Thanks.


#6

We are looking into the issue regarding the long load times.

We just letting players know part of the cause of the issues. We do suggest trying other menus in the game and letting us know if it’s just one spot you are getting stuck or are there multiple places (and what those places are).

We also to try a full restart (quitting the app entirely and then restarting it), to see if that helps, as we’ve had some players which this has worked for and others where it hasn’t.


#7

it stucks in many loading screens
like raid pvp arena …
i use a tablet with android system


#8

This is the only thing that’s lets me get into a battle. One force quit lets me do one battle. The second battle after the quit results in the same endless loading screen.


#9

In a different thread, Cyrup suggested deleting and reinstalling the game. This actually worked for me.


#10

#11

We’ve updated this thread with important information. If you are experiencing this issue please link your account and reinstall the game. A player has also provided a workaround for the issue which you can try before reinstalling if you wish. Reinstalling is more reliable.

We are looking into some permanent solutions in the mean-time.


#12

The workaround did not work for me so I did the full clear-data, uninstall, and reinstall. Worked perfectly for me.

Edit: I’m on Android.


#13

Nope… Can’t even load up dungeon on Android. Cannot load the artwork for Arcanus and all the unowned pets in the Show All screen in Troop Menu.


#14

Completely Deleted and reinstalled game, linked my account and then reentered game, this worked for PVP but NOT raid boss i entered a battle and loaded for 30 minutes and still nothing force quit, lose sigil are these likely to be returned. How long on average should i wait is 30 minutes not enough? Slightly frustrated but understand teething issues as explained above. However are we likely to get re imbursed for lost battles/sigils due to needing to force quit through sheer frustration.


#15

Losing Sigils here too


#17

Anything crap update that just makes my game worse


#18

Just wondering if load screen issue is occurring when it should be loading a battle against a gnome. I haven’t had a single battle against one of these new pet gnomes at all since loading the new update. Is this possible?

Thanks!


#19

Raid boss still isn’t working for me, even after completely reinstalling. Android 7.0.


#20

Here’s what I have used for a workaround on iOS - not perfect but no lost stuff, just a bit of time.

IMPORTANT: look at all troops carefully in the “Scouting” screen. If all of the artwork has loaded, you are OK to proceed.

If any of the little rectangles representing your troops or opponents is black, look for the spinning circle in the lower right. If that is still there, just wait until either the artwork has fully loaded or the circle is gone. This should only take a few seconds.

If the spinning circle is gone and the artwork has not loaded, DO NOT ENTER THE BATTLE. The loading screen will just spin forever if you do. Instead, close the app entirely and reopen it.

Go through the same process again - this time hopefully the artwork loads. If not, grit your teeth and try, try again.


#21

Well I logged on and it got Stuck on loading screen so i did suggested tip of reinstalling and it took my sigils!!! Very angry about this