Game lags when accessing Troops and other menus (Fixed in 4.2)


#42

@Cyrup thank you for a detailed update. As annoying as it is, it’s reassuring that the issues have now been identified so that it can be fixed asap :+1:


#43

Just curious why the lag didn’t effect the devs in their office while they played and tested?


#44

They didn’t had to exchange teams, since they were all using “Ishbaala Divines”. :stuck_out_tongue_winking_eye:


#45

Hi

I’m using an Apple IPad Mini 64G, version 11.2.6 (15D100), model ME278B/A

Once the freezing slowness starts it doesn’t go away unless I turn the iPad off and put it back on.

Regards.


#46

Any updates Cyrup?
If not, a simple ‘No 10 chars.’ will suffice.


#47
  1. Android/ mobile Level:1122
  2. Ich spiele meist 1-2 Stunden und es fängt so ungefähr ab 10 min an zu hängen sobald ich Truppen Info oder PvP kämpfe anfange.
    3.Geschwindigkeit 4x
    4.ganze Zeit durchgehend
    5.nix

#48

Sorry, I was typing a response and forgot to send. This! Basically what I said last time; there are some minor improvements that will go in with 4.0 but otherwise no new updates from Unity on the core issue. I am sorry.


#49

That mean we will need to reboot console every 30 minute for another 2-3 months.


#50

There are some improvements to the issue when accessing menus that will go into the game with the next update, 4.0.

Otherwise, this fix is out of our hands regarding an exact ETA. Depending on the severity of your issue you may not need to reboot the console, only restart the game.


#51
  • xbox one, around 400
  • Playing for 2 - 3 hours at a time, usually I start playing and just jump in with little breaks for tea in the process etc.
  • Opening troops menu. First time - it freezes, next I can open troops menu multiple times without issues. Same goes for going back to map from long session in pvp (10+ fights). Same thing when going back to the map from explore (20+ fights)
  • 4x
  • Every day now, each time I play longer as stated above.
  • Sugar is a poison lol :slight_smile: That money would be better spent on souls/traitstones etc :wink:

#52

Nope, 4.0 didn’t help out at all at least on Xbox. So all the lag is Unity game engine fault?


#53

@UKresistance, further fixes are coming with 4.1 to help mitigate this issue. You have posted about this in several places, and we have commented before. We are doing what we can to fix this, and we understand your frustration, but there is nothing more we can say or do at this time.


#54

OK, so how much has this been resolved in 4.1? We were told great improvements in 4.0 also.

And I posted twice, not several. My first post was closed.

Continuing the discussion from Unity still causes unreasonable lag that Unity is unable to fix so Still NOT solved:


#55

The fix in 4.1 is reduced lag when opening the Troops menu.

Regarding the continuation of this discussion, to clarify, I don’t think there’s anything else we can say.

The issue is caused by the game pulling information when accessing certain menus and performing other standard tasks. This is different depending on the account and can be worsened with more active players or players with huge quantities of Troops/resources, so the improvements may not have had a large impact on you. As this is an issue with the way Unity works the team has taken measures to improve to the problem to the extent that they can.


#56

giphy%20(68)


#57

Well, I guess no more complaints until 4.1 hits. Thanks for the additional info, but it can’t be caused by too many resources (50M gold or glory). Too many troops/pets/weapons graphics when the menu opens due to a memory leak sounds plausible.

PS

I got mad when Salty laughed off the issue her last stream.


#58

This is … totally still a thing. I get it every day I click on the “Edit Teams” button or similar. Gems goes to “not responding” and makes me wait. Usually 30-60 seconds, about 3-4mins this time.


#59

i 2nd this. from the main screen entering the troop menu the load time i would not call fast but it much better than before. However, using the edit team button from a pre-fight menu the load times are as long as ever


#60

This is still a regular issue on PS4 and you don’t even have to be on long before it starts. I guess it is another issue that will never be fixed :-1:


#61

The devs have stated what the issue is this is not a Gems of War developer issue.

This is do to a memory issue in the Unity engine. I assume they have been in discussion with them on this matter. Also fixing memory issues with engines is a very deep complex process that can take time, we just need to be patient as it is out of their hands at this time.