Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Fully traited faction troops showing as untraited in TDH Faction Assault

Platform, device version and operating system

  • iPad Pro 12/9” (2nd gen), iOS 13.3.1

Screenshot or image

  • included are 3 images: 1 - showing all Deep Hive faction troops fully traited; 2 & 3 showing that in a delve run/battle only one is fully traited, even though I traited first, then went into the delve.

What you were expecting to happen, and what actually happened

  • I expected all troops to show fully traited. Didn’t happen. Which is odd, because I followed the same procedure (traiting then fighting) for a different hero on a different generation iPad and there was no problem there. I did check to see if the effect was only visual, that the troops are acting as if they are traited, that it’s just not showing. But no, no trait activity is happening.

How often does this happen? When did it begin happening?

  • it happened in the first round of battles (9 fights) of the delve/FA and I didn’t go any further. Not much point in running a pure faction team when they aren’t fully traited. Perhaps next FA that takes place in The Deep Hive will be better.

Steps to make it happen again

  • ok, I started the second delve run (lvl 30). Same problem. I can complete, so I haven’t wasted a sigil. At this level traiting isn’t as important. But I won’t be trying again w. this team until I find out if I’m doing something wrong (?) or there’s a small bug in the game.

(upload://qE4qf8CoGUR6EqKhFhIrF8GwlVq.jpeg)

this image didn’t show up for some reason:

UPDATE: I tried again, TDH level 40. Same team. Beetrix is so impressive that I decided she could do the whole delve herself. And suddenly the traits are all there. Ok, problem solved. And a mystery remains.

2 Likes