Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Controller has bugged out the whole game

NOTE: This is a community-drive category. A developer may not respond to your post. If you need help with Gems of War please contact support here. To report a bug go here.

Whatever problem it is that bugs out the controller settings on PC needs to be fixed. Every time I connect my Xbox controller for whatever reason, it bugs out this game and makes it impossible to play.

Currently, I am unable to use the Settings icon to open the menu, because every time I move the mouse, it flickers on and off, and when I stop the mouse - the icon disappears. Not ONE single button on ANY of my controllers does anything now. Everything just sits there and flickers while the mouse is moving. Should I even manage to open a window, like a kingdom page or the event page - it just sits there with the available settings flickering in sequence and the close button will NOT activate. The only thing i can do at that point is force-close the game from the desktop.

This is the worst it has ever been, but this is a problem EVERY DAMN TIME I connect my XBOX controller. Or remove one of my other controllers for some reason.

Every.
TIME!

Why?

Screenshots or video:

There’s a ‘Disable Controller’ option in Settings > General.

It was added at some point because they wouldn’t or couldn’t fix the underlying issue causing violent UI spasms with controllers.

I am pretty salty about the whole situation right at the moment, so I am venting a little. But … I know about the Disable Controller option. My problem is that it does not work.

I have:

Turned off controller in settings - Multiple times.
Restarted the game.
Restarted Steam.
Disabled controller support in Steam.
Restarted the computer.
Cold Booted the computer.
Shift-Booted the computer.
Disconnected the power. (unplugged it from the wall, went and ate lunch.)
Reinstalled Virpil's drivers.

I currently have it working - by disconnecting every single controller I own and uninstalling the XBOX controller device. So, in order to play this game, I have sidelined $1,200 in flight controllers - that I use daily.

Nothing?
Nothing at all.
THis is still a problem, and in fact it is worse now than it was last week.
Last week I was able to use most screens except for the actual battle screen.
This week, I cannot use any screen that requires me to select an option, as the options just cycle repeatedly at high speed as if I am holding a key down.

I would put this in the bug reports section for a better chance to get it looked at.

Is this a new issue for you? My husband has been complaining about it for what feels like years :frowning: He basically gave up playing GoW on his PC because he didn’t want to unplug 2-3 controllers to make it playable.

I filed a support ticket, but I’ll try bugs as well.

Its not a new problem. It’s one that was supposedly fixed. It resurfaced for me about three weeks ago. I had it cleared up last week and it is back today. Which, to me, means that they changed something in the update for the new campaign week and it broke the controller options again.

The “may” is really misleading. They should update it to “WILL NOT” respond to your post.

I’ve been on the forums 4 years now and have saw a developer respond to a thread on every category of a thread except for “support” threads.

I honestly don’t know why the threads exist. I tried tagging @Lyya asking for the category to be removed. Maybe I’ll have better luck with @Kafka (only not tagging Salty because she’s on Holiday.)

In regards to the OP.
Unfortunately what I’ve been told in the past is PC/Mobile Gems of War isn’t designed to be played with a controller. So at least back then they wouldn’t support any issues that come up when trying to play with one.

Hands or a mouse are the only approved peripherals.
Which sucks for managers like me. Who has a member who experiences severe pain when using his hands to play Gems of War so he would ideally use peripherals designed to work with disabled individuals like himself.

But why worry about accessibility with there’s monetization to be done.

How many holidays do Australians have? It seems like many more than us.

People in different parts of the world call their vacations “Hollidays”. I’m not Salty’s Personal Assistant so I can’t be certain. Since all she said was “she’s on Holiday”. But I’m assuming she’s on the vacation type and it’s not an Australian holiday.

But the confusion is why in America we don’t call Personal time off…a “holiday”. 🤷 Lol

2 Likes

According to Twitter she’s on a personal vacation which is typically 20 days a year. And yea that’s called being on a holiday in Australia, as opposed to a public holiday, which we also have a number of (depends on the State/territory you live in). Would be nice if whoever runs GoW doesn’t just rely on one person to address pressing issues though :roll_eyes:

Hey, sorry some of you are having this issue.

When did this start?
Do you just have the one controller plugged in? Or multiple?
Is your Windows version fully up to date? Did this start after a Windows update or after the latest game update? Sometimes making sure Windows is fully up to date will solve controller issues.

Are you trying to switch between playing with your mouse and the controller while playing Gems of War or are you just trying to play with the mouse while the controller is connected?

Do you have issues with the controller/mouse in any other games?

Also, correct we sort of use holiday and vacation interchangeably here.
Public holidays are when the entire office is closed.
Salty is currently on leave, it’s not a public holiday.

2 Likes

Perhaps I am not being clear. I am not trying to play Gems with a controller. I want to play with mouse and keyboard. But I do use a controller for other things (most recently Wreckfest.) So I do have to connect a controller occasionally. But every time I do, GOW gets screwed up somehow.

This is what I am dealing with: https://youtu.be/W0BUD9L6rdc

At this point, not only is the controller not connected - but I also deleted the device from Windows. And it was working on Sunday, but went all to hell again today.

I did submit a request, and I’ll do the bug ticket.

Gems of War (probably any other game) can’t tell if you’re trying to use a controller for the game or not. Unless there’s an option to pick one over the other in the games options.

So the only solution. (in my opinion)
Is to unplug the controller.
But if you want the devs to actually weigh in on this, you have to change this thread to bug report is essentially what I’m trying to help you with.

(Nevermind I see (Kafka is here now.)

A short video showing the problem I am having: https://youtu.be/W0BUD9L6rdc

Windows 10 1903. This started about three weeks ago when I connected my Xbox controller to the system to play something else. I have always played GOW with mouse and keyboard when playing on the PC. I have never used the controller to play GOW.

I do have other controllers connected - specifically Virpil Flight controllers and a set of rudder pedals. I have not had a problem with them before now.

The Xbox controller has been disconnected, and that device removed from the system. That was last week. And on Sunday - everything was working fine. Today when I logged in, it was all messed up again and I had changed nothing.

Edit: Currently, the only updates I have for Windows are Office updates. The update for 20H2 has not been made available to me yet.

I’m curious if you have the issue with the xbox controller when your flight controllers aren’t plugged in. You should be able to play the game with unused controllers plugged in but I can see from the video that something is kicking it back to the controller. This usually only happens when a controller is used (which you’ve made very clear you’re not doing). If it was as simple as a sticky button I’m sure you’d have worked that out by now, so I’m wondering if it’s a thing with having the other set of controllers plugged in and it kicking around between the different controllers for some reason.

You don’t use a touch screen/tablet at all do you?

I do use a phone/tablet regularly - when I am not home. If I am at home, I use the PC, and will often play GOW in the background while doing other things. So, in order to meet guild reqs and other things - I can play elsewhere.

That is not a solution.

Additionally - https://youtu.be/6dwZN-fU_B0

I literally changed nothing. I went to bed and it was not working properly. Now, approximately 10 hours later, it is working fine.

Again - I changed nothing. I tried to play on the PC, it was broken. I went to bed. Several Hours Later I started the game about 15 minutes ago - and it was fine.

What in the actual hell??

https://youtu.be/W0BUD9L6rdc

Are your flight ‘controllers’ actual controllers? Isn’t the game supposed to display button overlays when using a controller and all throughout the UI? If your controllers are programmed to advertise themselves as additional keyboards or mice or similar, then the ‘Disable Controller’ option can’t fix your issue. Your best bet might be to disable your flight controllers in Windows’ device manager until you actually need them.

Both controllers identify as “Game Controllers” and report as HID-Compliant Game Controller, HID-Compliant vendor-defined device, and USB Input device under hardware. Neither one of them are programmed with any mouse or game-controller (RB, LB, X, Y, etc.) specific commands. Just axes and Windows buttons.

Under Joy.CPL, when at rest there are no active switches or buttons. Nothing is lit up.

When GOW is acting up, if I switch off the disable controllers option, the game does display the button overlays. Those disappear when I turn the switch back on.

I was asking about the tablet/touchscreen not to give you an alternative way to play but to see if you had any such devices plugged into your PC as a possible cause of the problem rather than your Xbox controller and flight controllers themselves.

I couldn’t tell you why it’s working after you went to bed even though nothing was changed, we didn’t change anything on our side.

If it starts happening again, I would go right back to basics, unplug all controllers, check for the issue - if there’s no issue - plug one thing back in - test again. Plug the Xbox controller in last. See what happens if you have just the xbox controller plugged in but not your flight controllers as well.

If we can identify what combination of things plugged in is causing the problem it will help us pinpoint the exact problem.

2 Likes