Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Can't load invasion battle on mobile

What you were expecting to happen, and what actually happened?
Unable to enter invasion battle. The screen just shows the loading screen. Have waited for 2 hours (went afk cos working) and came back and it is still loading. Had to restart the game and in the process 1 sigil was lost. Tried entering invasion battle again and same thing happens again and now I’ve lost 2 sigils. Unwilling to try again to risk more sigils.

What are the steps to make it happen again?

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!
Just ss of loading screen.Screenshot_20180618-171858

1 Like

I bought till last tier. So should have 52 sigils. Here’s a screen shot showing 50 sigils left, and no progress in the invasion. Screenshot_20180618-193239

1 Like

Waited the while night. Tried to load invasion battle once more and still endless looping. Cannot get jnto battle and have to restart the game. And again another sigil is used up. All my other battles are able to be played, although I noticed that the card portraits needed to be reloaded all over again.Screenshot_20180619-080802 this is getting real frustrating.

I have had issues as well today. Game has froze while loading an invasion battle costing me a sigil. Has also froze on dungeon, and twice while loading PvP matches. I’m on Android.

Hi All,

Please check out the known issues article for a similar problem to try and resolve this issue: Infinite battle loading screen

Otherwise the team are looking into this now.

1 Like

Hi @Cyrup,

I’ve had that issue after 3.4 launched with pets. And resolved it by reluctantly reinstalling.

This one appears to be different. Only with invasion battles. All other battles are so far ok, just have to wait out their portraits to load before starting the battle.

I Just received 3 sigils in my in game mailbox. So thanks for that. But I’m unsure whether to try again without knowing that it is fixed, otherwise I might lose another sigil for naught and trouble everyone for the refund again. I opened a support ticket yesterday, and after seeing the sigil refund, went to check my email but there’s no reply yet so I’m still unsure if the issue has been resolved.

Hello @oodumboo - Yes, at first in order to give you some kind of workaround while the team investigated I shared the older article with you; as often asset downloading problems have similar resolutions :slight_smile:

The development team identified the cause of the problem and pushed out a fix just a little while ago to resolve this issue! Please try closing/reopening the game and loading an Invasion match. It should be working smoothly now.

Thanks! I’ve verified that it is working fine now. Just played one invasion battle. Cheers!

I received compensation in the mail. Thank you or whoever else from the team was responsible. I’m assuming it was from my post above, because I did not submit a support ticket.