Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Cannot Ascend Troops / Ascension Broken

Platform, device version and operating system:
PC (Firefox, Dell XPS 8930), Gems of War 4.2.0.07, Windows 10 (64bit)

Screenshot or image:
Self Explanatory -> Any ascend screen.

What you were expecting to happen, and what actually happened:
I was trying to ascend my troops. Each time I enter the ascend screen I can no longer interact with the client. Cannot ascend, close screen, or click anything else.

How often does this happen? When did it begin happening?
Every time.

Steps to make it happen again
Go to troops. Choose troop with ascend icon. Go to ascend screen. Click anywhere or do anything.

1 Like

Thanks for letting us know about this.

Can you please make sure your account is linked to your email address and then reinstall the game and let me know how you go?

If this doesn’t solve the issue, please take a screenshot or video of the issue as although it sounds like it’s self explanatory - actual screen capture of the issue is always useful.

1 Like

I am also having this same problem since the 4.2 update.

PC, Windows 10 (64bit)

I am having the same issue after updating. iPhone 6S iOS 12.0.1

https://imgur.com/a/6nze4n4 (Video of bug)

Edit: Reinstall did not fix it.

Yep. That’s the one. Thanks for the video, Renji!
Logged onto my wife’s computer, and this is definitely account related. She can upgrade her troops just fine, but there’s still no ascension if she logs into my account on her machine.

Reinstall doesn’t fix the issue. This machine says it is registered to my email under the game options menu. Could it have something to do with the migration of my hard drive from an old machine to the new one since I started playing the game again recently?
Edit (Actually that doesn’t make sense. Why would that be it when it won’t function on my wife’s computer?)

Just started playing again, not a great reintroduction to the game when a major part of the game just doesn’t work.

Same problem, cannot ascened troops.

And the fact that it freezes the game on that screen is annoying on top of that.

Exact same problem, screen freezes and requires an Alt-F4 to get out of it. I presume it was the 4.2 update that broke it.

thanks for letting us know everyone and letting us know which devices you’re on and the video @Renjixfen

We’ll be releasing a potential fix today hopefully.

Please let me know if you still have this problem after say 24 hours from now?

You fixed it! Well done. Thanks Kafka.