BUG: Can not use weapons in Arena


#1

Resolved through Support
(thanks wasn’t sure where the form was to submit when i made this they resolved it quite promptly though once i found it, thank you)

What you were expecting to happen, and what actually happened?
Expected that my hero could equip and use weapons in arena.
Actually when I click the area to equip a weapon on my hero in the Arena lobby it brings up a blank (black) menu and no button for the weapon menu appears. If I click my hero during an arena match without a weapon equipped to check my cast stats, a similar blank menu appears. However if I then close this menu I am unable to cast any troops abilities for the remainder of that arena match.

What are the steps to make it happen again?
Start an arena match on my account/computer and attempt to equip a weapon to my character.

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!
http://steamcommunity.com/sharedfiles/filedetails/?id=805602815 (Clicking hero in lobby, no weapon button, blank menu)
http://steamcommunity.com/sharedfiles/filedetails/?id=805602860 (Clicking hero in arena match with no weapon, blank menu)

links for images to lobby before clicking hero, or battle after it locks me out of casting a charged ability of another troop also available but they both show little and would exceed the limit of two links.


#2

I’ve done my fair share of arenas, but this is a first time I see something like that oO

Arena hero should have auto-equipped the last weapon you used on your hero, per default, for a brief moment I thought maybe it bugged if you never used the hero with a weapon before. But I think from the very start of the game, it has the Crude Club already equipped right? (it’s been a while).

Just a few questions:
a) did you play arenas before and it worked OK, just this one bugged out?
b) if yes to the above - did you try to abandon the draft and start a new one, to see if it works or it still broken in a new arena?


#3

Hi here happens the same.

Maybe you need to put a ticket to support team.


#4

I use Steam as well. I just finished an Arena run and had no problems. You can try to validate the game files under the Steam library. Right click on Gems of War and click properties, then go to local files and then click verify integrity of game cache. Support told me to do this when my hero disappeared and it fixed it. If that doesn’t work, then definitely put a support ticket in.


#5

I don’t recall if it ever worked correctly on my account, but I have done arena on another account on a different computer quite easily (so I know i’m not overlooking something).
I have tried it multiple times, it happens every time now. I have won arena (8 wins despite it), I have lost from it (2 losses), and i have retired with it in no case did it resolve it either during that run or in future runs.

I have tried to use Steam to verify integrity of cache and it didn’t find any problems.


#6

If you haven’t already, I would contact our support team here: https://gemsofwar.zendesk.com/hc/en-us/requests/new