Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Anniversary rewards bugged?

Opened Day 1/5, don’t see any of the loot. Troop had code instead of a name.

The same thing happened to many of us. I don’t think we were awarded the gems or gold either based on another person’s post (I wasn’t paying attention to my totals of those so cannot say for sure)

Ah, cool, I’m sure they’ll fix it then, thanks for confirming.

same on XBOX no troop reward even though it said there was one.

Xbox same happened too, tried to restart and now even when I check claimed mail its not there.

Android the same. Read mail seeing rewards, but no loot there. In mail history it s listed as received.

Ok now the Troop card received. But not the ressources.

PC here. No mail, no troop, no nothing. Restarted the game, still nothing.

Likewise. Troop pops up at first but isn’t actually the troops list. Fairly confident that I got the 100 diamonds, unsure about the gold. That was mobile, console worked as intended.

Whatdyarecon? Send in a support ticket? Or hold off? See if it happens again tomorrow?

And what did we get?

They are discussing this in another thread. Sirrian says the rewards will arrive “later in the day”, anyway looks they are coming here and there. It seems the game has to be restarted, anyway.

1 Like

Fixed it on android by force stopping the app (actually clicking force stop, not just swiping it from recent apps) and re-opening.

I got the following:

Screenshot_2017-11-06-10-52-07a

1 Like

Didn’t realise we were getting any resources :thinking:
I got a troop with a strange name and a weird description, that is all.

yeah. Also mail and no reward. any idea how to fix it?

After reloading several times, still no new troop. I received the 100 diamonds and gold though.
Also Kraken and Trolls have mana requirement updated but its still written that troll create 4 gems and Kraken still show create 9 gems and 40% chance to devour. Im on Xbox.

1 Like

Take one look at the UI and tell me you expected the developers to handle tasks like “creating a new troop”. Hell, somehow “adjusting Wisp and Kraken” caused “every troop that targets” to break.

I don’t think they’re stupid, but all of these simple errors are characteristic of, “We didn’t have enough time.” I’ve sort of lost my confidence that I’ll be playing this game for much longer if they’re this frazzled and overworked. It feels like we’re a few weeks away from the studio being shuttered.

4 Likes

But is it in your inventory?

After opening up some glory chests, I received another one also…Nothing there.

I use iOS and got the notice on mail box after the reset. I saw the new troop, but Tzathoth is not on the troop list.
and there is no Tzathoth I can find. Where is he ? Is this the bug?