3.4 Known Issues (PC/Mobile/Console)


#122

Fixed for you :stuck_out_tongue:


#123

oh sorry i missunderstood her
than


#124

Unfortunately this didn’t help me get in to pet battles on iOS - thanks for the hint tho :+1:


#125

Descriptions of Orc exclusive traits should be updated to clarify that they activate when the unit losses life OR armor


#126

Can anyone else not type in Guild Chat? Whatever I type does not show up. :frowning: Now I cannot reply to stuff, it makes me sad and lonely. Especially since people are talking about the bunny in guild chat.


#127

Chat is working correctly for me again. Thank you devs!


#128

Explains why ours has been quiet all night actually


#129

Just got another pet event triggered by someone in the guild.

Had to restart client to get notified that it was happening.


#130

Haha, what? So in order to get tribute, we need to check for mail. And now you’re saying that even that is insufficient for triggered pet events? I’m glad the devs reduced the download size at restart.


#131

Why are the rewards for pet rescue not collected automatically an the end, as the hour is gone, if not collected manually…?

As i logged in, i had 8 minutes of the event left, got to the 6th fight and in the middle of the battle there popped up an error screen that the event has ended…


But as i wanted to collect my rewards, there came the same error screen…

So i fought for nothing… :rage:
Nicely done… :confused:


#132

A guild mate has the task ‘win six battles with 3 unique gnomes’.

Whoever thought that was a good idea clearly doesn’t understand what gnomes are and how there’s only 2 right now!


#133

The above is not true. Doing an explore battle was sufficient to trigger a pet rescue notification.


#134

Ermmmm…

Nevermind still happening :frowning:


#135

Search issue:

“Sol’zara” turns up no troops. To get her to turn up, you have to search for “Sol’Zara”. Note the different apostrophe/single quote, even if it is rendered as the same character by Discourse. The default on the iOS keyboard is the wrong one.


#136

I had the same issue, and I got so angry!


#137

How can I get this? I didn’t have any rewards.


#138

I wish i knew, both of my kids that play dont have it, but me and the wife did.

Only difference really was we play mainly on steam, but android as well, and they are both only android.

We had also updated before new day, they hadnt.


#139

guild chat and chat in general not working since i updated. even tried reinstalling. Android


#140

not sure if this is by design or not…

on completion and close of the 8th and final pet rescue battle i received a popup “Event is Complete” or something like that. I had not claimed any rewards yet and no rewards were allowed to be claimed. going to the rewards menu showed 1-7 ready to claim, but the same event is complete popup is shown if clicked on. i guess the winning battle #8 didn’t count since i was after the event was complete(even though i did win it). i did not receive any mail with unclaimed rewards. …all 8 battles done for nothing…

Additionally, i looked around on all the pet rescue menus and did not see any count down timer for the event. it would be nice to know inside the Pet Rescue menu how much time you have left.

Android 7.0
GoW 3.4.0.13

  1. can we please be able to claim available rewards after the event is over?
  2. can we please get mailed unclaimed rewards?
  3. it would be nice if the timer only stopped you from going into a battle. not waiting for you to finish to then tell you its too late. but…i leave this one open.
  4. can there be a countdown timer added to the Pet Rescue main menu?

#141

My husband experienced a similar thing. The event expired while he was in a match and he never got his rewards from it. He was unable to claim them and they weren’t mailed to him.

Is that by design or just not working right?