3.1.5 Known Issues (PC/Mobile AND Console!)


Anyone else having these issues?


It starts tomorrow, the Schedule updating is a little slow, we already know this.


OK I was just checking normally I’m not on this early.


XB1 bug?

The Dwarven Miner on the enemy team is able to remove skulls and bash your teammate. Your own Dwarven Miner can not do this. He can only remove certain color gems. It happen in any mode.


Not just XB1. But I have never actually used Dwarven Miner myself to see this! I just assumed Dwarven Miner could target skulls because the AI always does.


Also can you put down on your list of things to do: fix the unobedient defense team setting so that we can set a defense team that actually stays as the defense team. We need some sort of “Lock it in, Eddie” button.


Neither have I until it was reworked. When I saw the enemy do it, I thought I could but couldn’t. No telling how many other units have similar bugs.


weird issue - I play using the Steam client. I usually make moves my clicking on the gem I want to move and dragging it in the direction I want to move it.

If I do this on a gem that’s:

  1. in the first three columns
  2. in the first 5 rows

While I still have the left mouse button held down I find that the settings screen pops up and I have to X out of it to get back to the board, while the move animations play behind the settings.


Yup. On iOS, my Dwarven Miners can’t target skulls but the AI’s can. What a weird issue.


I don’t see Emperor Korvash on the list of troops with bugs at the moment, but he is definitely not working correctly. I fought against a defense team that was using Emperor Korvash, and when he cast his spell, he drained and true damaged my first two spots. I lost my second troop during the spell, and then my third troop also got all his mana drained and was hit with the true damage. I know I have seen other people post about this exact same thing happening to them…is there any fix coming out for this? @ozball @Saltypatra


AI cheats finally confirmed!!!


I’m seeing a weird graphical issue on iOS after the 3.1.5 update. When I make a move, I see the gems removed, then the opponent moves and I see only the gem movement/cascades, then after all the gem movement is completed and it’s my turn again, all of the overlay graphics (“Mana Surge”, explosions, spells, souls, etc.) are displayed all at once. I tried changing the graphics quality and animation speed settings but it didn’t seem to make a difference. I’m using an iPad Air 2.

I checked on my Android phone, and the overlay graphics are displayed in “real time” with the gem movement as before.

Has anyone else seen this?


Do you have Power Saving mode turned on on your iPad?


Speaking of animations, can the “takes damage to life” animation be scaled back a bit? When a troop does AoE damage to life, the grow/shrink of the heart icons is distracting. And for something like Kraken, the animation is sometimes ongoing while the next matches are cascading.


I am having the exact same problem on my iPhone (7 with last update) it’s also caused the battles to slow down as well. Also happening on my iPad.

Tried restarting and same issue. Happen both with low power mode and normal power.


I have a serious guild war question. Why is it for six weeks in a row including this week we are continuously playing the same Guild first? I thought they changed up the way we play each other. Any other guild seeing this besides the guild I am talking about? They know who they are.


Are you always the same position? Cause @Shiratori found how GW schedule
Work and team #1 always will fight the same team position. Same for every other team


I have the SS. Same guild first. No matter the position.


Mate Shiratori left the game and this forum. He wont be back


I know bro i didint want to page him, i was just saying he found a patern and knew
Exactly the order every guild will fight