Xbox one goblin rocket purchase didnt work

I purchased 3 goblin rockets today and they are not appearing in my troops list, i sorted the troops 3 different ways and quit the game and came back. The glory purchase went through however and i am missing what i spent.

I just bought 6 on PS4 & they are not showing up for me either.

Me too, bought 3 and not showing up on PS4, the “show all cards” button doesn’t even show the Goblin Rocket as an option at the moment.

Same(ps4). I bought 7, and have none. I’m going to submit a ticket at 505 games support though, as I don’t think the devs here can do much about it.

Hey folks,

I’ve also notified 505 about the issue… they’re just getting in to work, so hopefully they can resolve it nice and fast.
To anybody else experiencing the issue on PS4/XBox, follow the link to 505 support


Same here tried to purchase a few and nothing showing. Purchased 3, but they didn’t show. XB1

So excited about this because I’m using a goblin variation team right now, but when I tried to purchase them I get the same results as the previous posters (XB1). :frowning:

On the plus side, I’ve noticed that under guild progress it does list an additional troop as being owned. I’m guessing that we technically have them, but aren’t being allowed to see/select them. It amounts to the same thing atm, but would mean its probably much easier to fix.

That’s good to here! The goblin has only blown up on the launch pad then, let’s hope for a quick fix eh. :slightly_smiling:

505 just got back to me, they are looking into it now. Nice and quick on the reply, good stuff.

1 Like

Nice and quick on the reply, but what about the solution? :wink: They give you an estimate? Thanks for the update! :slightly_smiling:

“we’re definitely going to look into it right away and get a resolution provided quickly as we can!” 505 verbatim

That’s as good as it gets in the world of support tickets from my experience. Hoping for the best here.

1 Like

I’ve been responded to as well now. No eta, but I would have been surprised if I’d been given one. We’ll just have to have some patience :stuck_out_tongue:

1 Like

Thanks guys! :slightly_smiling:

Hi all – the reason why we don’t have a solution for you is because the developer isn’t in office yet. :slight_smile: We’ve reproduced it on both consoles, and have sent the issue to Pipeworks, so now we have to wait for them to get back to us so that we can get back to you. :slight_smile: Thanks for hanging in there!


Womp womp wahhh. So this doesn’t sound like a quick fix hehe. In any event, no pun intended :stuck_out_tongue: how come there are imbalances in the amount of troops per kingdom? Having level 15 troops levels the kingdom in the console versions exclusively (aside from the challenges and quest which only gets you 2) and all the kingdoms don’t even have the same amount of troops. Seems like a pretty obvious balance issue to me, as you can’t get all kingdoms to the same level. Thoughts? Thanks!

Nothing yet, my ticket is still open, crossing fingers that Pipeworks is fixing the pipes. I’m not sure about the balance Lady Sapphira, I would say they are leaving room to add cards later, but that’s only a guess.

Thanks for the update! Yeah, I understand what you mean about leaving room. Moreover, I also get that some of the kingdoms have event troops that some of us can’t get until they are offered again I guess? However, even that being said, if you add Goblin Rocket to the Zaejin roster on the console, they still have 1 less troop overall as compared to others.

So what I’m saying is, all things considered, Zaejin, prior to the Goblin Rocket addition to the console, was 2 behind other kingdoms, just for example: Khaziel.

Just seems counterintuitive to me, as I would assume that the kingdoms would be balanced as in, add one troop to each kingdom until they all have 6, then 7, then 8, etc.

Perhaps I’m missing something? @Sirrian @Nimhain @505GamesSupport :slightly_smiling:

1 Like

Well seems everyone is experiencing this problem and not just me. Hopefully it will be fixed for everyone in the near future.

Same problem here on ps4 seems i bought 2 by mistake thinking maybe i didn’t click all the all through the first time when i checked and didnt se it…My question is there a place to submit a ticket for refunds?