What the hell just happened?!


#1

You see this too right?! Sorry for TV lines; this one is kinda worn.

Also, I recently started an Xbox One run, naming my hero after my OC’s namesake. This screencap is from that.


#2

Also, if it matters, this is in Arena.


#3

Ok you Deathmarked who?

I guess I’m not sure what you’re talking about.


#4

No no no. In Arena you’re supposed to have a full team of 4 troops. You can see three. The opponent has to have the same number. There is only one, the hero, apparently, and he is apparently suffering from EVERYTHING but poison. And if traits still work, there is no way in Tartarus this person would already have all 3 on his hero unless he paid gangbusters for traitstones and keys. Assuming classes work in Arena, which I have to say isn’t the case. This is the worst glitch I have seen in this game thus far; I had to retreat and quit the match just to get back onto the world map.

EDIT: I just saw the freeze debuff /)_-


#5

And when you tried Arena again, did everything come up normal?


#6

No! I tried getting in again and it didn’t even let me in the match!


#7

Quit the game and restart the console?

Sounds like you have a bug.


#8

I don’t think the console is the issue; I’m playing another 505 Games offering, Battle Ages, with no problems.


#9

It’s the standard PC fix so why not… clear out anything and restart the game just in case something went loopy.

If it’s still a problem, uninstall and reinstall the game. If still a problem, contact technical support.


#10

I think I’Il try my solution first: wait some time and try again later. Maybe the server decided to be a butt again.


#11

“… be a butt …”

LOL!


#12

But either way, that was a MASSIVE error. Is that a one-time thing or might others see it?


#13

I’m scared to play Arena now :confused:


#14

hugs TaliaParks


#15

Arena was normal for me when I cleared it.


#16

On top of the above image I got the dreaded “this battle may have already finished or one may have already started” error message when I attempted to retreat.


#17

Topic Bump


#18

YES! This exact same thing happened to me yesterday.

I was annoyed because I was at about 6 wins and 1 loss in Arena when it happened too, so I thought for sure it would count as my second loss. I got the same “battle may have already finished…” message as well.

Fortunately, I was able to exit out of the game, then come back in, and all was well, and it didn’t count as a loss. But yeah, that was very strange. Glad I’m not the only one!

On another strange note, my Tasks have completely disappeared now. I did a couple earlier today, and now when I came back after work they are just GONE, and not like they’re hidden by L/R buttons. I want my 10 gems, goshdarnit! :slight_smile:


#19

See @Shiratori? It can happen to others.

@Nex
@Mr.Strange

Please look into that. I don’t want to break either of my GoW consoles.


#20

Ok. Still doesn’t change my mind that you’re crazy, pony.