Update broke game on XBOX


Well, it’s been over a week now. I’m probably thrown out of my guild, missed out on all of the daily / weekly / monthly bonuses, and I assume whatever (I think it was guild wars) weekly guild event was going on got NO help from me.

WHEN ARE WE GOING TO BE ABLE TO PLAY AGAIN? And are you devs going to restore all the items we WOULD have gotten if we were allowed to play?

We have some fixes that will help with this issue coming in the 4.3.5 update. However, they may not help all players, so we are still investigating further. We will do everything we can.

As @larvi has said, it looks a fair few of these issues are caused by the OS and the way it connects to the internet. Sometimes even when it is connected it will act like it isn’t, which in turn negatively affects Gems of War as it requires a stable connection to play.

In regards to compensation, it is something that our team is discussing. We don’t have anything to announce yet, as we don’t have a clear plan on what we will or won’t be doing.

Can you give us a clue when the 4.3.5 update is due to come out?

Wow, this is really taking a long time.

If you didn’t see the updates to the official post for this issue already -

I’m very sorry :frowning: Unfortunately, this problem will not be resolved until the next update 4.3.5 as it requires an update to the game client/application and is out of our control. In the mean-time, you can try the steps outlined in this article (as linked above). Some players have found these helpful and they work for you to temporarily resolve the problem.

If you haven’t already please submit a ticket with a screenshot or video of the issue if you are affected by this issue so we can organize compensation when the issue is resolved.

@Cyrup It’s been 2 weeks already and we still can play the game. When will 4.3.5 be launched?

We don’t have a firm release date for 4.3.5 yet.

Hello team!

We have some more information. If you are using your X Box One in the beta, or preview mode, Gems of War will likely be affected and cause this issue.

Please disable it and see if this helps. (And let us know either way!)

1 Like

Leaving the preview program is not enough, you have to leave, then reset. It just worked for me.


@kfdavila Hello! I’m going to give it a try and leave the Xbox Insider Program to see if it also works for me. It’s something I already suggested 12 days ago to be the problem but it seemed not all the gamers were on the insider program and maybe only now the devs could really look in to it. But what do you mean by reset? Just to restart the console (power cycle), right? (And not a factory reset).

Left the Xbox Insider Program. Restarted the console (power cycle). It didn’t work. I continue exactly with the same problem.

I had to RESET my console after leaving the preview program @enanenes not a power cycle. You are still running a preview build. Factory Reset /w Keep Games and settings worked for me.

Thank you, @kfdavila. I don’t want to do a “hard reset” (deleting all games, apps, etc), so I will try a “light one” as soon as I can (OS and xbox accounts deleted).

But doing a reset like that was what @pseudostuga did, who wasn’t in the insider program, and it worked for him.

So, doing a reset may fix it even if people don’t leave the insider program (as I also did).

I’ll let you all know how it worked as soon as I can do the light reset.

Did the reset (keeping games and apps) suggested by @kfdavila and I could play. Since that happen once before the problem started and I couldn’t play next day, I’ll write tomorrow if I can still play.

@DenXD @sprayer @Larvi might want to try leaving preview program and factory reset as well. Was the only thing, out of all the suggestions, that worked for me.

Did you use the reset option with keep games and apps or did you remove everything when you did the factory reset?

I DID keep my games & apps when I did the reset, that option worked fine for me. I also forgot to unplug my 8tb external, and it still fixed the issue. From where I am standing, and that’s hardly science, the main problem was the preview build of the OS. After you leave the program, you need a reset to get the normal os on there.

1 Like

Can confirm that a factory reset worked for me as well, and I stayed in the preview program, just did the reset. And it also appears that all of the network errors are gone as well now, so possibly some corruption to the system network stack that gets reset when you do this. Great tip, thanks so much!

I’m going to do it on my other console at some point as well as while gems works on that I still get network timeouts.

All is well after these days with the @pseudotsuga and @kfdavila solution.

So, for short, it seems whatever the update broke has only one solution: a factory RESET.

You CAN keep the games and apps and there is NO need to unplug your external drives and kinect.

You also DON’T NEED TO LEAVE the insider program because the gamers who didn’t leave the program - as well as the ones that weren’t in the insider program - also fixed the issue only by doing the reset.

This happened to me and I tried a different approach: changing the language on my console. Restarting. And then it worked again