The AI does not see the extra turn

Steam Computer Win10

mistake.png (sorry)

What you were expecting to happen, and what actually happened:
Collected a T-shaped five, wanted to tap the weapon after that, but the move was given to her opponent

How often does this happen? When did it begin happening?
Either it happens or it doesn’t, 50/50, in PvP and guild wars

Steps to make it happen again
Collect a T-shaped five, which will count as two threes

Troop frozen?

1 Like

Of course, not frozen, that’s something I would have noticed and taken for granted…

1 Like

I assume you are talking about this shape, do you?

It should give an extra turn, if you move the bottom red gem up.


Yes, thats right thats gives a extra turn.

Is it possible to get video footage of this if it happens again? We would be able to give a much better analysis if we could actually see how it actually happened.

Yes, people have claimed incorrect “Extra Turns” from time to time, but rare and elusive enough that we really can’t research it without video.

For example, if you are using Nexus (or Wyrmrun) troops whose abilities create a match-4 or match-5 at the start of your turn, this does NOT grant an extra turn because it’s not the action you actually spent your turn on.

1 Like

Yes, that’s right. This action can give the move, or it can give the move away - yesterday and today it started…

I’ll try to catch it with screenshots, I can’t do video

At least it’s a start, but it still requires finding/anticipating a situation where it happens again and being fast on the capture button.

The best way to grab video – and which is actually standard on some consoles like Switch – is via retroactive video capture. How it works is the software is already automatically background recording a certain amount of video (e.g. 30 seconds), so any time you see something notable happening you hit a button and it exports that background capture into a video file. It’s so much more convenient than standard video capture (especially for rare and/or elusive incidents like bugs) it’s not even funny.


LOL I witness all of the time that the A.I. would get an extra turn off of a 3-match instead of a 4 or 5. LOL

It’d help the devs fix the bugs if people would capture videos, otherwise it’s going to keep happening.
If it’s happening all of the time, then it should be easy to get a recording.

1 Like

Video proof or it never happened.

I’ve been playing this game since 2020-ish and I’ve never ONCE found an Extra Turn with no legitimate explanation.

Yes, I’ve had dozens of incidents where I thought an Extra Turn was being handled incorrectly, but upon reviewing my video footage literally every incident so far has turned out to be a legitimate match of 4 or more gems, and in most cases not even at the top of the board (i.e. NOT caused by gem drop RNG).


by the law of meanness, it stopped giving moves - either there was a one-day random error, or random got scared, and the theory of observation comes into play - when you watch closely, mistakes do not happen.

But the dart broke…

I tried everything, up to and including auto, but it only helped to get out of combat.

1 Like

The extra turn on a 3-match started happening around a little over a year ago. You meant to say, “Post a video of it ever happening”.

Xbox has an option to capture the last 2 minutes. Since it happens all the time, you can easily post a clip to prove what you said wasn’t another bs claim.

1 Like

That “option” is nothing new, you’re just now discovering that? And why’re so emotional? LOL

Did it happen to coincide with e.g. Wyrmrun or Nexus troop debuts? Abilities that create Gems at the start of each turn have the potential to yield a match of 4 or more gems, which can cause an “Extra Turn” notification to pop up after making your move (even a match of just 3 gems) but that is just a bug, and the game is functioning correctly otherwise.

This can also work on PC games utilizing the “Xbox Game Bar” in Windows 10 (exact options are found under Windows Settings > Gaming). Try hitting Windows + Alt + G and see if anything happens.

1 Like

I tried playing around with the video recordings, and decided it was easier to swallow than to delve into this new and questionably important and necessary thing for me.

I want to pish-posh and move gems, not all this…

So alas, but video recordings - I can not, the maximum - a stream in discord, and then, because there only need to press the button, not this is all :slight_smile:

No, before that.

Okay, but just only reinforces the need to get actual video of it happening.

We can never rule out potential bugs, but … as I said earlier, I’ve literally NEVER seen an extra turn (or lack of) that didn’t have a legitimate explanation when reviewing the footage of it.

You look like you’re playing on Windows, so did the key combination do anything? Even a “no” is a good answer here, I’m just interested in seeing my question resolved (and I don’t play on PC myself so…).

First I had to go into the settings to enable this function, then when it still didn’t respond I had to assign a folder, then it sent me to the microsoft website to say that I was me and not some spy who wanted to steal my data from my computer, then I pressed this combination and. And nothing happens, nothing is added to the folder, there’s no new processes in the manager…

And I don’t want and won’t install any side programs like Radeon Video Professional Super Ease Premium Elegance, for some reason I don’t trust technologies that know better than me how to manage my disk space…

Something like that)