Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

(Resolved) Xbox One -- UNEXPECTED_ERROR_NULL

Please check the known issues list before posting a bug.

Note: If you are uncomfortable reporting your bug publicly you can privately message @Cyrup or @Kafka with the completed bug template.

Platform, device version and operating system:
Xbox One

Screenshot or image:
Will update with a screenshot as soon as I have it ready.

What you were expecting to happen, and what actually happened:
This is simply what you were trying to do and what happened instead. Example:
‘I was trying to start an Arena battle, but Gems of War loaded Broken Spire quest instead!’

Just trying to play. Finished my first PvP match of the day, and received “Server issues” message. Exited from the game, stopped it, and restarted it. Upon trying to restart, received an “UNEXPECTED_ERROR_NULL” message. Stopped the game and restarted again, and still receive the same message.

How often does this happen? When did it begin happening?
Was this a once-off bug or has it been a consistent issue? Does it only happen after doing a particular game mode?

See screenshots below for how things look when I get into the game now.

Steps to make it happen again

PNG

PNG

PNG

Restart your xbox and Gems should be fixed next time you start it.

1 Like

I have tried that twice already, which led to the two lower of the three screenshots above. But will try again. Thank you.

You restarted console?
At worse you may have to reinstalll gems. there is no save file, it is all linked to your gamer tag.

1 Like

Yep. Let console sit for fifteen minutes and have restarted it again, and still, the issue remains as shown in the bottom two screenshots above. No names, and everything showing in brackets, except for my Gamer Tag and my Guild.

I have never had to uninstall / reinstall before. Do I just go to “Manage” and “Uninstall,” and then just find the game in Xbox store and install it again? Won’t lose anything, right?

Yeah, and you won’t lose anything. Wont even have to restart the intro.
The game cache got corrupted, it happens occasioanlly and reinstall is easiest way to fix it.

Maybe try and delete save data reserved space?

1 Like

Since it seems to be having an issue with the labels and names for things, I don’t know if that is where that data is stored or not.

Oh! Try switching language in game to something else and then back to english

1 Like

The download message you sometime ssee at start of game, that includes the name labels and stuff is what is corrupt

2 Likes

Uninstall and Re Install. it will download (2) 505 mini data updates you need afterwords. should fix it.

2 Likes

Thanks, both of you! Uninstall / Reinstall worked! Likes all around!

2 Likes

Glad you could get that sorted quicker than I came in @EnsignGarak! Please check your in-game mail. If you need quick support please feel free to check out the Technical Support section of the help center, you’ll find this article here:
https://gemsofwar.zendesk.com/hc/en-us/articles/360000210256-Text-for-icons-are-missing-on-Xbox-

If you could please let us know:

  1. What language settings is your Xbox on?
  2. Is this the same as the language set inside Gems of War?
  3. When the game first started to show the issue, did it download anything when opening?
1 Like

This issue of corrupted data download (possibly the reason) should be examined in more detail. It just happened to me a few days ago… and happens to enough people on xbox that many players know what to do automatically (hint: that is a bad sign).

  1. XBOX Settings Language: English, Language Region: English (US), Location: United States
  2. Gems Settings English
  3. Just after the daily reset (a few days ago). Gems was working just fine before the Daily Reset
1 Like

I agree, it’s an issue! We’ve recently had more reports since Friday but so far you are the only one to include some information on those questions. We have a lead for the problem but may need more info. I’ll do what I can to help the team iron the issue out.

1 Like

I’ve never had anything set other than English language. I can’t say if anything downloaded, but in my case, as I indicated earlier, I had just finished my first PvP match of the day, and the issue had not yet started. At the completion of that match, I got the dreaded “Server experiencing issues – Please try again later” message. I hit “Retry” several times, and the message kept popping up. So, I hit “Quit” instead, went “Home,” and hit the menu button to “Quit” the game. Without restarting my console, I started the game again, and it was at that point that the bracketed, unnamed labels appeared. I do not know if there were any files downloaded during that process.

2 Likes