[Reported] Ogre Fury trait not working

Platform, device version and operating system:
Steam and Android

Screenshot or image:

What you were expecting to happen, and what actually happened:
I was expecting to see attack increase by 1 after matching red gems (as per Ogre Fury trait description) - red match on far right column in this particular case - but none of the four troops with Ogre Fury trait had their attack increased.

How often does this happen? When did it begin happening?
It happens every time red gems are matched and started happening, I would wildly guess, as soon as Broken Spire rework was released live and Ogre Fury trait added to the game.

Steps to make it happen again
Have troops with Ogre Fury trait present on a team, match red gems, sit back, relax and enjoy the show…NOT.

Using the right trait name now. Thank you for correcting.


First, make sure we do not not confuse Orc Fury with Ogre Fury:

  • Orc Fury - “Gain 3 Attack when I take damage.”
  • Ogre Fury - Gain 1 Attack when matching Red Gems."

Can confirm “Ogre Fury” trait is not working, including on Switch. Even if you bring only a single Ogre to battle, it simply does not trigger. Ever. At all. Period. Player and cpu alike, it does literally nothing.

How does a bug like this even make into beta, let alone through?


the same reason Ace of Wands gives 1 magic on cast


And the same reason our issues are ignored and given little notice outside empty promises…the couple of people working on the game just don’t care

1 Like


Thank you very much for letting us know about this. I have reported this to the Development Team to investigate why Ettin’s second trait isn’t working. and get a fix out asap.

OminousGMan - Support Human :male_detective:

Technically it seems to be the trait itself, not just Ettin specifically (though Ettin is an easy example for having it as a non-third trait).

I expect this will likely involve some kind of clientside fix?

Interesting update on this.
Just for the fun I tried out again and…(matched 3 green at the top right, in this particular case)

…Ograk Shaman (troop in slot #2) now gains attack on any gem matches (except for skulls) instead of just red which, I believe, was not the case in the time of opening this bug report; other troops with Ogre Fury trait are unchanged - still no attack gain on red matches.

Hey @Dust_Angel

I updated the initial report with your latest comment, but it appears this should get resolved with the 6.7 update.

Jeto (she/they) - Support Human :woman_mage:t2:


Looks like no fix for this.
As far as I see Ograk Shaman still gains attack on every mana gem match while Gog & Gud, Ettin and Ogre gain no attack at all.

Similar to when Barbarian class was released. Or when Tartarus got souls for every color match.

We’re hoping to have a fix out for this if not tomorrow, then next week. Sorry it didn’t make it into 6.7 as originally mentioned.


Quick update:

We will be changing Ograk Shaman’s Trait from Ogre’s Fury to Warded.

This is because if the Troop with Ogre’s Fury uses the same colour as the Gem that needs to be matched it causes the Trait to trigger with all Gem matches not just the intended one.

That’s a very odd bug… :thinking:

Hope you can figure it out and change it back when it works properly.