[Reported] More and More Images not available on IOS

Platform, device version and operating system:

Screenshot or image:
See below

What you were expecting to happen, and what actually happened:
I expect to see the image of the following units and their spells:
Spike (Pet)
Orpheus Priestess
Axe Beak
First Caw Maanes
The Bane of of Mercy

How often does this happen? When did it begin happening?
Always. It starts whenever a new unit with the glitch is first seen on screen and thereafter.

Steps to make it happen again
Just Turn on the game on IOS.

I seriously don’t know why you allow this to keep happening - previous messages to me state you know about this bug and are “working on it” - how long does it take to fix this and keep it from happening with other new units?


Hello :slight_smile:

This is a currently known issue with the development team which has already been reported and is undergoing construction/fixes.

It is high on our priority list, and unfortunately fixing assets is a much more complicated task than it seems.

Thank you for your patience :slight_smile:

It would be helpful for us to have more granular updates than “reported” and “fixed” on these long-term issues. It’s gone from a minor annoyance on iOS to a major one. A little better communication about the identified problems and challenges being worked on would go a long way.

Add me to the list of players with missing images. All of the listed above. iOS.

Problem on Android is similar/same - we’d also like to hear from the team now and then.

Remember, we don’t know why it’s so difficult to fix, nor how far you’ve come and how likely it is to be fixed anytime soon.

1 Like

Update on my original post - after installing update 6.9 - all images I had issue with, except for Spike the pet, are STILL MISSING!!!

This is still not fixed in 6.9 on iOS despite the notes claiming otherwise. I downloaded assets, and didn’t get stuck this tine, but the images that were missing are still missing.