Princess Elspeth and Sacrificial Priest can kill your Doom troops!


#1

Platform, device version and operating system:
PC, Steam client, Game: 4.2.0.07, OS: Win 7x64 SP1

Screenshot or image:
Not provided.

What you were expecting to happen, and what actually happened:
Any Doom card is invulnerable when fully traited.
It cannot be killed instantly by lethal attacks or magic spells that sacrifice it.
I am not sure about Zuul’Goth, though.

Example:
Sacrifice and Widow Queen can’t kill your Doom troop, but create the gems or do the damage - not a bug.
Princess Elspeth and Sacrificial Priest can kill your Doom troop - a bug.
The Zuul’Goth, not tested.

How often does this happen? When did it begin happening?
Always. Not sure, probably since the 4.2 update.

Steps to make it happen again:
Refer to my Example case to replicate this issue.

@Cyrup, @Kafka
If you still think that you need a screenshot, video or more details, please, let me know.


#2

Lethal is different from Sacrifice/kill…
Not a bug.


#3

Elspeth and Sacrifice (troop) spell says kill ally.
Elspeth kills the doom, Sacrifice not.
Widow Queen and Sacrificial Priest spell says sacrifice ally.
Priest kills the doom, Widow Queen not.
So, it is a bug


#4

I edited my post to include the inconsistent text that the developers use that only exasperates the confusion.
Still not a bug though.


#5

If Sacrifice and Widow Queen don’t kill Dooms then that is a bug then.


#6

Yes…I had to reread to catch that.
Widow Queen would be the bug.

Dooms should be killed by any ally troop if able to Target that troop for instant death.
Yep, just tested it.
Widow Queen SHOULD be able to kill a Doom and it’s not.
Probably wasn’t even tested by QA.


#7

Could be working as intended, sometimes you just can’t tell :crazy_face:

Is that silly broken spider working as intended? If not, I won’t draw anymore attention to it :zipper_mouth_face:

Now for a good widow queen / doom deck :thinking:


#10

Is that silly broken spider working as intended? If not, I won’t draw anymore attention to it :zipper_mouth_face:

What’s wrong with it?


#11

I’m checking this with the team


#12

I think Elspeth never had instant kill. Her spell actually just deals damage to your troop equal to their current durability.
A while ago, before 4x speed and not casting until animations trigger, you could time your cast, while the target is getting life from it’s trait, and it would survive with exact amount of life it got from the trait.
Priest might be coded the same, but since he doesn’t have empowered it’s not realistic to do


#13

Hey folks, any troops which instant kill/sacrifice an ally should always succeed even if you have an invulnerable ally.

We have some older troops on a different system which will be updated in the future to function correctly.
This includes Sacrifice and Widow Queen.

We are also in the process of ensuring all our wording will be consistent in the future.