Option to Disable Sparkle Effects


#1

Just as the title suggests the sparkle effects are too much, please allow the option for players to turn this off as it is very distracting.

Imho this should be a huge priority as this affects one’s ability to play the game and I can’t imagine how bad it will be for those that have vision problems. Please hotfix this asap before Christmas.


3.2.5 Feedback and suggestions
#2

Option to revert UI back to original. :wink:


#3

I’m on steam and can’t see the changes yet (which might be a very good thing), but have heavy vision problems. Could you post a screenshot or two of those things in effect so that we who don’t know what you console guys are talking about yet can weigh in at least a little bit?


#4

I’d love the option to disable them, but would also accept them turning off automatically for lower graphics settings.


#5

Wow, more UI effects introduced without involving player feedback?

Gems of War. Gems of War never changes.


#6

:joy: you immediately made me think of 40k:

“To be a player in such times is to be one amongst untold thousands. It is to use the cruelest and most bloody UI imaginable. These are the tales of those times. Forget the power of UI design, for so much has been forgotten, never to be re-learned. Forget the promise of progress and understanding, for in the grim dark future there are only unnecessary particle effects. There is no peace amongst Krystara, only an eternity of changes for the sake of changes, and the laughter of thirsting publishers”


#7

I don’t like the new status effects. I didn’t think they’d bother me this much when I saw the devs introduce the update on their previous stream but now having it in hand it’s very unappealing,and visually distracting. The game is going in an unfavorable direction. Please get rid of these new status effect visuals. The traits are too small now on the troop cards. This by far is the worse update in GOW history for me. I was ok with the first overhaul but the finished product has too much going on.


#8

I don’t mind them at first glance, but I’m sure they’re gonna get real old. And I can also see how they would be bad for some people. Definitely a bizarre thing not to have an option to disable.

I mean, why can we disable the mana costs, which is essential information, but not fancy effects?


#9

The sparkle effects make the game experience near unplayable.


#10

Someone in the Unforgiven family played 1 battle and quit game and discord because it gave them migraine.


#11

Like the new-original? Or the old-original? Or the original-original?


#12

Well, I get migraine as well after one battle and quit for now, but still hope for a hotfix and stick around like last time and try not to panic this time…:neutral_face: That person was quick to leave… hope they come back at least to discord to learn if there will be a hotfix or not.
But yeah, now that I can see it too - and posted a lot about it in the suggestion/feedback and news thread - I can also speak for myself in that the game is unplayable for me with the particle effects.


#13

Yeah I’d like to jump on this one - I’ve been playing for about 15 minutes on steam and it’s affecting my vision. I have no eyesight/migraine issues but this is leaving bright spots on my retinas. I can’t believe this was play-tested for any serious length of time.


#14

I don’t mind the new effects on the board, but the craziness on status effects is too much.

An option to disable the board effects for everyone concerned would be good.

Status effects should not be how they are.


#15

I still think people are using the wrong settings on their displays tbh, but I appreciate it’s personal choice and people do have vision problems. Personally speaking, I like the new effects for the most part.


#16

#17

I checked out your topic and it seems more for console users/people who play on a TV screen. I still tried to mess around with my PC settings but can’t fix it. The thing is, the gems look for me like they do in your “good” setting while the fireworks look like they belong to your “bad” one.


#18

Thanks for the concise reply and checking out my thread. That’s why I posted it in the console section but just wanted to try and help people who are struggling. I totally get what you mean in your response and yes the effects are still pretty bright with correct settings. Unfortunately the effect that needs to be bright (freeze), isn’t!


#19

I also think a lot comes from the fact that people are playing on 4x speed. I just checked out 1x speed and it’s, thanks to the slower animations, more bearable (but still way too bright). At 4x speed, flashes are everywhere. But I think most people play on 4x speed…

Here’s a beautiful screenshot of mine to show my colors (since I’m colorblind, I am not sure if they match your ‘ideal’ settings 100%) and the comparision between gem colors and the damn spell flash.


#20

I can totally get why people would like an option to disable the effects.