Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

New tool analyzes your collection and tells you which kingdom power tasks you can do right now (based on gowdb)

As we all know, kingdom power levels (stars) are very important in this game. But digging through your troops to see which ones you can trait for the next tasks can be very tedious. Good news - I made a tool that does it for you! It’s a Firefox add-on that enhances the excellent gowdb.com Collection page to show an overview of all your tasks in one compact, sortable table. It calculates which troops you have the traitstones for and highlights tasks that can be completed immediately (and which troops to trait). It also shows the minimum amount of souls you need to finish “level X troops” tasks. As a bonus, it shows the next level’s troop-related task as well.

You just need to connect your GoW account to gowdb.com (it only takes a minute) and install the add-on. Then go to your collection and click the new “Analyze Tasks” button at the top left. The data is updated directly from the game on each page reload!

Here is the add-on

Shout-out to my peeps in the Throne of Odin guild family!

Feedback is welcome!

33 Likes

I haven’t tested it yet, but this sounds awesome! :star_struck:
Could you create an option to check whether it’s possible using major/regular orbs of wisdom as well? :innocent:

Interesting idea! Unfortunately, the gowdb page does not have your orb data, so I can’t calculate anything like that. You do see the number of troops left to trait for each task, so you need to compare that to the number of orbs you have.

1 Like

Amazing tool, thx! Does it work too using public url (the one that you use to share your collection)?

Yes, that works too. It always works on your own collection as long as you are logged in, otherwise it still works (on any collection) but can’t see the resources, so the traitstone tasks won’t be analyzed.
P.S. And you’re welcome :slight_smile:

2 Likes

Nice app! :+1:

Perhaps you could flag “not achievable yet” tasks in Red, eg for Broken Spire “Level 22 troops to 20” can’t be done yet because there aren’t 22 troops available.

2 Likes

Does it work for Switch-Collection?
I have the addon installed and am logged in in my collection. But there’s no button on the website.

Thank you for the tool.

@Rockwell Added red coloring to unachievable tasks, thanks for the suggestion!
@locoblutaxt GowDB allows integration with all GoW platforms and the tool should work, but I can’t test it. The button should actually always appear on collection pages though, maybe try reinstalling the add-on?
@Poisy You’re welcome! :heart:

2 Likes

I had a similar issue (button not showing) and solved it be enabling the plugin option for anonymous session/pages (I don’t remember the exact words)

Hmmm… I think I know what you mean - but it didn’t help…
I mean: There are not many options. I turned the option on that’s below the “automatic updates” option.

Hm, there are actually no add-on-specific options here. You should see a brown button in the top left corner of every collection page. The only thing I can think of is that you might have some other add-on that could block this one somehow. Maybe try on mobile (or desktop, if you were on mobile before).

I manually deactivated all other addons to test if it works. No difference.
Maybe I’ll try an other device as you said. But not today.

The button appeared fine for me and I run all sorts of blockers (eg uBlock, NoScript, Ghostery etc)

Maybe try clearing cache and history and reload?

I just installed it and the button also doesn’t appear for me on my Switch collection. Can any Switch players verify it working for them?

Thank you very much for creating and sharing this nice tool!

1 Like

Awww no love for us chrome users? :frowning: hehe nice work though dude! (Y)

This works pretty great :smiley: Thank you very much!
If it would be sortable, especially by power level I would have a gemgasm :stuck_out_tongue:

@locoblutaxt @Evelyn Guys, could you post links to your collections? That might help understand the problem better.
@Stix It is sortable, click the headers :slight_smile:

1 Like

I can confirm that the tool isn’t working for me either with the Switch platform.

1 Like