Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[KNOWN ISSUE - Fixed in 5.5] Pvp battle stuck on enemy turn

Skip to 1m20s. Didn’t trim the video as I think my phone’s video editor worsens the quality when I trim videos

2 Likes

Assuming you’re talking about only one Account (so no alts) and just making sure. You’ve definitely updated to 5.4 on all devices you play on?

Yes,: Android, single account, 5.4, all assets downloaded upon update.
:relaxed: :vulcan_salute:

1 Like

Then it’s definitely not going to be fixed by forced update. :slightly_frowning_face:

And the reason we aren’t seeing more reports of it is probably due to the hero classes that are immune to Lycanthropy.

So far only the classes that aren’t immune have posted.

In this thread only Android and iOS are seeing the issue.

Any steam reports?

@Fourdottwoone so you were right it doesn’t have to do with the other players information. But the reason we’re only seeing it in pvp is that’s the only place the combination of Essence of Evil (easiest way to cast Lycanthropy currently) and an opponents Hero is possible outside of Guild Wars anymore.

Works on both sides of the battlefield:


Stuck in attack, same symptoms.

At least thanks to forum QA (i.e. the only real QA) we’ll be able to advise our guildmates against using EoE during Green Day, and to be extra cautious if facing EoE.
:relaxed: :vulcan_salute:

3 Likes

If the issue isn’t happening on Steam then even the beta was powerless to it. The bug is soley on the mobile side which as far as I know (which I’m not on the beta anymore) wasn’t tested. It’s just very unusual for a beta to be tested on a mobile in regards to GoW by the players anyway. QA is another story.
They are supposed to test these things. But what else did 5.4 change besides Lycanthropy for them to test all this time? Lol

1 Like

The annoying part is, I really can’t tell if the Lycantrophy effect is visible before and after it gets stuck, it’s just a huge glob of swirling chaos. :see_no_evil:

1 Like

I’ve had it happen on Steam last week, my brother has had it happen to him on Steam as well.

2 Likes

Alright real QA.
Who knows how to edit the code to make it so you use your hero without using a class?
And then test it on that.
Because the game only seems to lock player players out when using Hero classes in pvp (or training battles) that aren’t immune to Lycanthropy.
But I’m curious to see if it’s due to something with the way the class system works or what.

Just had it happen to me on iOS iPhone 8. I’ve faced this opponent a bunch of times in ranked PvP and I’m pretty sure they are active in game based on the Leonie Crown stats.

1 Like

New theory is it’s happening on any Hero class not immune to Lycanthropy when Lycanthropy is cast on it. At the very least in pvp. Could include other game modes.

1 Like


Same symptoms.
:relaxed: :vulcan_salute:

1 Like

Next Phase.

For a hero class that isn’t immune to Lycanthropy. Figure out a way to have Bless be on the hero. And then try to cast Essence of Evil on it please.

OK Just done some testing to confirm a few things about this bug after discussions with @awryan about the bug and I believe I’ve made some headway:

For reference when I mention Lycanthropy Asset I’m referring to this:

20210402_061934
Testing on my main account on Live Servers.

Casting EoE on a Shaman Hero. Battle continues no problem, no lycanthropy asset visible

Casting EoE on a Bard Hero. Battle gets stuck on enemy turn. No lycanthropy asset visible

Casting EoE on Hierophant Hero. Battle continues no problem, no lycanthropy asset visible

Casting EoE on Tinseltail, no lycanthropy asset visible, no lycanthropy triggered

Casting EoE on Firebomb, no lycanthropy asset visible, lycanthropy did trigger and transformed into a nightwing

this got me thinking about why the asset is not visible, perhaps it is hidden underneath that blob of status effects, so I decided to start casting EoE on troops that are immune to a particular status effect so see if something was preventing the asset from showing (this was easier to test on troops than hero classes for this purpose)

Hunters Mark: cast EoE on Black Beast and Giant Crab, still no asset visible

Faerie Fire & Burning: cast EoE on Axolotl and Abynissia, still no asset visible

Death Mark: cast EoE on Anubite Warrior and Avina, still no asset visible

Web: cast EoE on Cocoon, no asset visible

Entangle: cast EoE on Cockatrice, no asset visible

Frozen: cast EoE on Borealis, no asset visible.

So this got me thinking, has the asset been removed…

Used Mountain Crusher, Magnus (3rd trait applies random status effect on 4+ matches), Luna (can apply 1-2 status effects with her spell) and Leprechaun for a faster start and I managed to get Lycanthropy from Luna and the asset was visible:

So what do we know about this Lycanthropy bug now:

The issue is with casting EoE on a hero that isn’t immune to Lycanthropy

Casting EoE applies lycanthropy successfully to troops because as per my testing and others on this thread, lycanthropy does sometimes proc and transform the troop into a random beast.

Casting EoE does not have the Lycanthropy asset visible on troops or heroes.

Asset is still in the game because it is shown when lycanthropy is inflicted via Luna’s spell

I believe that this missing asset is part of the problem with EoE and the game can not successfully move past the enemy turn because ‘Lycanthropy true’ can’t be completed on hero’s not immune to lycanthropy

12 Likes

Possible dumb question but how do you tell which classes are immune to lycanthropy?

The ones with “Fortitude” selected in Stone talent tree.

Maybe I misread but looked kike Shaman and Hierophant were referred to above as immune, but neither has fortitude?

Good thing we have our own bug busters in the community, since devs can’t be bothered :sweat_smile:

3 Likes