[Fixed] Rat Swarm still not available in owned/unowned

The 6.9 update came out 1 week ago, so it should be available with this weekly reset. It’s currently still not available. It doesn’t even show up in the unowned category.

Edit: It is “Available”, but not until they make it visible. Basically, almost available.


rat swarm’s release date (troop id 7386) is set to the future, that’s why it doesn’t show up anywhere.

Cheers, Gary.


My guild got Rat Swarm from gold chests, but it doesn’t show up in troops. Neither owned nor unowned and it isn’t locked to a kingdom. But it counts in total troops.


Confirm it is available in chests but hidden in game


thanks, I’ve edited my post. Partially available is nice, but still needs the last half of showing up in owned/unowned

Basically, the gary release date thing

1 Like

I can also confirm that it is also available however like @Hayabusa mentioned it has no kingdom on the troop card.


It said I got in one of Gold Chests pull, but I can’t find this card anywhere to upgrade or trait.

And like everyone says - Nothing shows up in OWNED or


1 Like

@Bramble same issue here on wednesday. no to sound like everyone else but isnt this what the beta is for?

1 Like

Also pulled Rat Swarm and it’s also not showing in my owned or unowned troops.

now the release date was removed, but Blackhawk’s kingdom data does not contain it as a belonging troop.

How do I know it is Blackhawk? I assumed that from the troop’s filename: Troop_K25_31, with K25 being the code for Blackhawk.

Cheers, Gary.


this is now fixed

yes it is, I can see it in the data as well.

Cheers, Gary.

One less thing to think about. glad its solved

Hello :slight_smile:

Rat Swarm should now be appearing in game

1 Like

Thank you for letting us know

1 Like

I knew it was a Blackhawk Troop from the picture background alone.

1 Like