[Fixed] Game won't connect with Google Play Games

Android 8, Moto G5 Plus

Game won’t connect with google play games saying it has timed out. Other games connect normally.

I tried connecting through settings - account option. I also tried launching the game through the google play games app. I couldn’t link on both cases.

The game is up to date.

2 Likes

Mine won’t connect either, same message as you get. Everything is up to date on my end as well.

I am now running 4.6 and it’s still the same. Even after complete wipe off game, play games cannot login.

Yep. Me too. Samsung Galaxy Tab S2.

Can’t connect (doesn’t even give a choice when the game first loads.) On Android 9.0, Samsung Galaxy S9+.
On my Chromebook it gives the options at the start up of the game, but I can’t connect from the settings or works map links.

For me it asked for a google account right on first run after the update. And it logs in google play automatically each time now.
On a moto g6, android 7.

Are you sure about that?
It’s doing some weird shit for me where it knows I’m playing the game but it won’t let me sign into my account from the game. So though at least a few of these achievements have been done. There’s nothing telling the account that I have completed them.




When I try to connect from gems of war settings I just get an error when trying to reach the server.

But worry not boys and girls. Any time I do a purchase from the game it recognizes my account without any issues at all. Weird huh? :roll_eyes:

4.6 has broken Google Play login for me, after it had been working for ages. LG G7 running Android 9.0. I use two different Gmail accounts on my phone, but only one of those for GoW. Sometimes but not always, when I launch GoW, it will prompt me for which Gmail address to use, and then it will login.

A related issue is that when I exit the game from the menu, it leaves the client running in the background. If I then try to run GoW again without first removing the client from memory, the game will auto-close to the desktop. A second attempt to run GoW will launch normally, at least until it gets to the Google Play login.

Devs need to get a clue about how Android works!!

2 Likes

Update to 4.6. When launching the game, there’s this screen of Google Play Games loading and it seems it has connected and linked to the game. But then (and again), going to settings -> accounts and clicking at “Sign in” (should’ve been “Sign Out”…) shows the same behavior: some loadings and a timeout message as before. Version 4.6 hasn’t fixed the problem yet.

Android 8, Moto G5 Plus

Lol… On my Chromebook I can’t exit the game and restart it again without it crashing. I’ve just learned to go do something that takes 5 minutes when I start the game up, let it crash, and it’ll work after. I tried to have issues like it resolved before but it was like asking someone who speaks a different language to fix your car. A lot of time and energy just to have the matter still not fixed due to failure to communicate properly.

Thank you for reporting this everyone. We are looking into this now.

Any further information would help us greatly. Could you please reply with your device, OS, the issue you’re encountering specifically, and whether or not you can access the game?

1 Like

Android 8.1 on nokia 8. Also tested on android 9 on Nokia 8.
Game works fine, Google play login doesn’t work in gow only. Get server timeout message trying to connect. Both button on world map, and log in on account settings.

It does pop up account select for Google play games. Time out is after that. During start up of game same select pop ups. But never logs in. No time out message, but not logged in once game finished loading.

Same results on on different connections. And to re-iterate, Google play games login and all related features works fine in every other game I’ve tried. Only GoW is having issues.

1 Like

This doesn’t seem like a unique issue at all. So I get that the standard template is to get all the information available as possible.
But it just causes people more time to report an issue that is literally already “known”.
Whoever said or thought it was fixed was mistaken.
I would happily do a video for shits and giggles but the the recording software stops on my phone because it registers that I’m leaving the game to connect to my Google account. And it can only record in game stuff.

I have a ZENFONE 3, Android 9.0 and every time I launch the game I get a textbox from google play asking me who I am and I have to click my google account (I only have 1), this started happening after I installed 4.6

1 Like

exact the same for me… wasn’t an issue before 4.6…

1 Like

Same boat here, Nox or Bluestacks emulator, I must click on my Google account eah time I launch the game.

1 Like

Our main concern is how this is blocking people from playing the game. If you can access your account by linking the old fashioned way, then please continue to do so at this point in time.

If this is causing Gems of War to be unplayable, please let us know.

It’s only blocking achievements from being unlocked.
But I’m unaware of any people that are prevented from playing the game.
My apologies if I misunderstood the original post. But I thought it was just about linking the Google account to the gems of war account. Not issues linking gems of war to the devices.
I’m sure this isn’t an urgent issue to resolve. It’s just one that mistakenly checked off as fixed when it hasn’t been. But Cyrup updated the known issues 4 hours ago so it’s now on there correctly.

We thought we had fixed the issue but it’s popping up again. This is something that other games ocassionally experience, so we are doing what we can to resolve it with the next update for a second time. Sorry for the inconvenience. :frowning:

Yeah, I’m glad I coulod clarify. We are concerned that some players might not be able to access the game, and are trying to get as much info as possible, hence asking for device, etc.

1 Like

I have a Samsung Galaxy A5 and as others, every time I launch the game I get a textbox asking me who I am and I have to choose a google account., this started happening after I installed 4.6