Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Fixed 4.2/Resolved] Game will not load correctly

Please check the known issues list before posting a bug.

Note: If you are uncomfortable reporting your bug publicly you can privately message @Cyrup or @Kafka with the completed bug template.

Platform, device version and operating system:

Screenshot or image:

What you were expecting to happen, and what actually happened:
This is simply what you were trying to do and what happened instead. Example:
‘I was trying to start an Arena battle, but Gems of War loaded Broken Spire quest instead!’

How often does this happen? When did it begin happening?
Was this a once-off bug or has it been a consistent issue? Does it only happen after doing a particular game mode?

For the past week when the game is loading it says lore text. Then when loaded the kingdoms have numbers not names. When i tried to play the doom tower, it was blacked out and would not allow me to select it.
I have tried to play all week but the same happens, Wed. Tried to rescue pet and thought it was going let me play but when i loaded the first battle all it did was stay on the screen before the gems drop. I waited for 5 mins before i finally reloaded the game and had to buy, because i like to get the pets.
Please help

Steps to make it happen again
Sometimes there are certain steps that can lead to a problem that may not be obvious!
Example: I lose once in the Arena.
I then exit to the world map.
I then tap on Broken Spire on the map and then tap Arena.
Broken Spire’s quest loads instead of the Arena

If you are playing on xbox here are the steps to fix it
https://gemsofwar.zendesk.com/hc/en-us/articles/360000210256-Words-are-replaced-with-code-and-numbers-on-Xbox

2 Likes

Thank you very much it fix the problem

Hey @Stoffs I’m glad the article was helpful! The team should have fixed this issue for the next update version 4.2 :smiley: