[Fix incoming] Flash offer didn't give me Shiny Keys

I noticed a time-limited Invasion flash offer in the top left of my screen. It contained a heroism potion (double magic for hero for Invasion), 20 invasion sigils, maybe something else (Edit: 50 VIP Points), and 4 Shiny Keys for AU$14.95. Before telling me I’m insane, I know. I noticed my guild likely won’t reach keys for some reason in the tier rewards and I wanted to stay on top of the new Shiny Troop achievements.

Anyway, I got the confirmation screen, was charged, and got the splash screen showing what I received. But I don’t have a single Shiny Key to show for it. Not in the inventory and not showing in the Chests menu. I have restarted the game and they still won’t show.

This was not the head start offer before Invasion. This was a 24h? invasion flash offer today.

Anyone else experienced this?

I’ll open a bug report if it’s not known.

Edit: mixed up my left and rights.

Edit: here is a screenshot of the offer a friendly member of the community captured for me.


I got the exact same issue. Never had to do a bug report before so, Ill try that next.


I received the keys; however, when I went to Chests and tried to cash them in it gave me an error and restarted the game. Now the keys aren’t there and I don’t know if I received tokens or not. There’s no search ability on shiny eligible troops, so can’t figure a quick way to go and look if some have them that I don’t otherwise expect.

1 Like

There’s a list of shiny tokens in your inventory. So far that’s the only quick way to tell.

Write a ticket at

That’s your directest way to contact support and get your missing items.

same for me, also got the error of not having enough keys when trying to open them (despite it showing that I did have them) after restart they were gone without getting the shiny tokens. a quick way to see your shiny tokens is within the inventory menu, (avatar top left -->inventory–>shiny tokens)

I got the error too with the game restart. Put in a ticket 8 hours ago and im still waiting on a reply

They’re in Australia. Not sure how long they will take in general but I think at that time they weren’t working.

I had the same issue and reported it. Even bought twice for US$9.99 but don’t have a screen shot. The developers can easily check this based on our reports that we didn’t achieve this. I’m going to stop buying anything until this gets corrected

Appears to have happened to me on the Xbox as well.

With the amount of times i’ve seen people get screwed over by not getting something they purchased, its taught to never spend actual money on anything that’s offered that I can’t purchase with the gems i’ve earned.

They have responded to me directly and this is now being listed as a Known Issue.

They are looking to fix it and get the keys owed to our accounts. There’s no ETA yet.

1 Like

PC windows 10

Screenshot or image:

What you were expecting to happen, and what actually happened:
Had zero keys before purchase, now have the sigils to play, but zero shiny keys in chest tab.


Screenshot (I have the same issue)


Thanks for the screen shot, I couldnt post it since it dissappears when they get the money :stuck_out_tongue:


got the same issue, in my case it looked at first as if I had got the keys, but when I tried opening a set of 5 shiny chests the game gave me an error of not having enough chests, had to restart the game and saw that my shiny keys were back at 1 without reciving any drops

1 Like

Contact support here:

They should be able to help you out.

Hey all,

We’ve just released a fix for this to stop it from happening any more.

Now, that this is fixed we are looking into compensation for the affected players.

There is a Help Center article here for the issue which we’ll update when we have any more news about this issue, fix and compensation:

We’re very sorry for this.


Is there a timeline for “compensation”?

You were smart to screenshot before purchase. I need to start doing that since this isn’t the first time something like this has happen to me. When it does, they seem not to know which offer I am referring to and/or I can’t remember what all it offered.