Error with new Notifications

Platform, device version and operating system:
Xbox One

Screenshot or image:

What you were expecting to happen, and what actually happened:
Attempted to sign up for web alerts in Chrome using link generated from game.

How often does this happen? When did it begin happening?
Have only tried once, and it has failed once.

Steps to make it happen again
I don’t know if this is happening to others or not.

1 Like

Thanks for the report, we’re aware of the issue and are investigating it.

EDIT: Please try again and you should be able to Opt-in now.

1 Like

Thanks! Try again in-game and generate a new link, or just go to E-mail and use the one previously generated?

Both should work, but to be safe it would best to try again in-game and generate a new link. Hopefully it works now.

Upon generating a new E-mail and a new link, I received the following:


Yet, in-game, the “Browsers with alerts enabled” row reports 0 (zero).

Try hitting “Opt-Out” and then it should allow you to “Opt-In” again. Unfortunately the browser already thinks it’s opted-in, but it’s not linked to the game because of the bug you encountered.


Thank you. I imagine that this is the desired result from the browser side:


Thanks again! Now to see if the game recognizes this browser being enabled.

Edit: Yes the game recognized it, and set up what I assume are the default notifications (since some were not automatically selected).

Hey @EnsignGarak that is the correct result! For a full list of possible notifications just check the Alerts tab or this article. Glad we could fix this for you.

Hello again. Overnight, there were no new notifications generated for me for Gems of War. Considering that we have a number of overseas (Europe/England) players in our Guild, I guess I find it unlikely that none were actually generated in-game. So, will notifications only be generated when Gems of War is running on Xbox (for me), or should I be receiving game notifications even when I don’t have the game loaded up on my Xbox One?

Thank you. -EG

Just to be safe: Do you have any kind of Adblock installed in your web browser? I do have one and wasn’t receiving notifications, so i disabled it on the GoW Web Alerts page/link generated. I can’t tell for now if it will solve the issue, but you might as well try this and see if your next tribute or pet event will be notified.

In case this is the cause for the issue it might be worth being mentioned/noted on the FAQ @Cyrup.

I’m not aware of any specific adblock software, aside from Kaspersky. When authorizing notification updates from Facebook, I didn’t have to do anything special for that to start, and I get those notifications regularly. However – Interesting to note that I didn’t get any Facebook notifications overnight, either. So if you have any suggestions as to where I might specifically look, I would be most grateful!

Look if Kapersky has any feature related to web browsing notifications on its configurations, GoW coding for notifications might be considered spam/virus threat when it tries to trigger a warning on your browser.

The anti-banner selection in Kaspersky is turned off, so I don’t think that’s it. I find it unusual that I haven’t gotten any notifications at all (much less none from Gems of War) since authorizing Gems of War to serve notifications to me, and not having changed any other settings on my laptop.

EDIT: Because I had trouble last night and it was suggested that I click the “Opt Out” option in the E-mail followed by clicking the “Opt In” option, I’m wondering if that “Opt Out” actually changed more settings than it should have changed. Just seems like all of my notifications are no longer working, even though they appear to be authorized (along with GoW notifications) in Windows 10.

EDIT 2: Check that – Just got a notification from Facebook, so it does not appear to be an issue with Windows 10, nor an issue with my Kaspersky protection.

Sometimes it’s just a strange behavior the devs couldn’t possibly imagine, they make mistakes, but it would be a bit unreallistic to expect them to anticipate anti-viruses and adblocker add-ons being triggered.

My suggestion to check outside elements was intended to help you cover more possibilties on your end. I’m not getting notification too, but i’ll see it in a few minutes if it was my Adblock causing problems, if not i might investigate other things and try to report whatever i find.

Small update, it wasn’t my Adblocker… I’ll see if it’s tied to my Mobile account being linked, as it wasn’t updated yet, so it could be causing conflict.

I was at work all day, and just loaded up Chrome. Notification from Facebook, none from Gems. I would speculate that this is not working as it is supposed to work.

Yeah, i tried some things on my end and nothing, at first it seemed like the notification were coming later by one hour maybe due the Daylight Saving, but then things start to behave weird…

я так и не смог зарегистрироваться ,что бы я не делал просто не проходит сохранения

Hi everyone, the team should have resolved the issue where some notifications were not appearing. Please completely force quit and reopen your game to see these changes and let me know how it goes.

It’s working for me now.