Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Crash at startup not fixed in 3.4

Platform, device version and operating system
iOS 11.3, iPhone 5S

Screenshot or image
Wouldn’t help. See description below

What you were expecting to happen, and what actually happened
Roughly 40% of the time I start GoW, it crashes during the startup. Instead of getting the “Loading Assets” bar, I get dumped unceremoniously to the home screen. 95% of the time, my next attempt to start the game will work perfectly.

The crash always happens after the black-and-white splash screen fades and is replaced by the kingdom background. Sometimes it happens before the Game Center banner appears; sometimes while it is still on the screen; sometimes after it has retreated. Always, the crash occurs before the “Loading Assets” bar shows up. If I see that bar, I know the game will start fine.

How often does this happen? When did it begin happening?
This has been happening for several updates now. I know I have reported this behavior previously. As mentioned, the crash occurs roughly 40% of the time.

Steps to make it happen again
On my phone in particular, the steps are to close GoW, use a bunch of other apps so the game leaves the cache, then start the game. I suspect the issue has something to do with my phone being so old, and its memory so full (15 of 16 GB).

@Cyrup can someone at your office with a crappy phone confirm my experience? I get crashes a lot in GoW, and never with other apps.