Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Console Patch 1.096 Known Issues

Feeling a little defeated after winning a battle on Xbox. I’ve checked my internet connect and restarted the console and the game, I’m not getting any of the reward.

Got matched against that s***ge guy again and still no gems

Lol i know i should check opponent name before taping button but im too quick

1 Like

Does XB1 have a replay function?

I didin’t took video it’s the same thing then other day i did on another video on older bug thread

Its always had recording & editing features.

To the point I sent Nimhain a message about sm###@ an hour ago with documentation. He is the only player I’ve run into that causes the board to never load.

1 Like

I reported several bugs in the last thread that have had no indication they have been fixed in the patch notes. I’m going to re-post them here:

  1. "I found a bug with one of the new tasks.

I wanted to start working towards my “win 12 battles with 3 unique red troops” task. My team was Jarl, Goblin Rocket, Goblin Rocket, Hobgoblin. I won the match and my progress was still 0/12. My guess is that it detected I had a duplicate Goblin Rocket so it invalidated progress, although the task description certainly wouldn’t imply that your 4th troop can’t be a duplicate, as I was still using 3 unique red troops.

I switched out one of my Goblin Rockets, won again, and progress counted. I would imagine the same issue is with all of the “at least 3 unique” tasks."

  1. "Found a new bug today with one of the new troops, Madrid.

Madrid’s spell says it should apply a random status effect only if there are 10 or more green gems on the board. twice now the AI has applied a random status effect on my troop where there have been far less than 10 green gems on the board. It appears as if it will always apply the status effect when the AI is controlling Madrid. I tested him on my team and he appears to work as intended when user controlled (will not cast a status effect with less than 10 green on the board)"

  1. “Found another bug just now, again with tasks. I have a task for winning 15 matches with 3 construct troops. I changed my hero to a mechanist class and made sure I have the perk making her count as a construct. I made a team of her, valk, and 2 other unique constructs. After I won the match I was still 0/15 for the task. My guess is that the game is not properly identifying that your hero is a construct with that perk (I did check and my team appropriately has the bonus for 3 construct troops, however)”

  2. "I found another bug today.

I cast Atlanta’s spell, which damages all enemies. Opposing team was Azris, Alastair, and Bone Dragon (first troop had died already).

Alastair had barrier. When I cast Atlanta’s spell, it should have done 8 damage to all troops (which would have killed Azris). Unfortunately the only troop that received damage was Bone Dragon. For some reason, Azris did not take any damage, even though Barrier was not cast on him - It was as if Alastair’s barrier also worked for Azris.

I’ll also note that when I eventually did kill Azris, it only showed the damage hitting for “-1” for the kill, even though he had 3 armor and 3 HP on screen. I’m going to guess these bugs are somehow linked."

  1. “New troops do not show the NEW if you open multiple chests at once and get more than one copy of the new card. For instance, Gorgotha was one of only 6 troops I still needed, I opened 50 event chests, and got 2 copies. There was no NEW notification.”

  2. "I’ve come across this bug a couple times. I’m not sure if it’s just visual at this point, devs can test that.

When you are in the screen to trait a common troop, go to a troop that has no traits yet, but you have the traitstones to fully trait it.

Before getting the first trait, it should show that it takes minor and major traitstones. Here’s where the bug comes in to play: As soon as you acquire the trait, the second trait will slow that it costs more minor and major traitstones, and no others. The number of traitstones needed for major and minor will increase, but it will not show that it takes runic traitstones for the second trait, even when it is supposed to. If you acquire the second trait, the same thing will happen - it will show you only need minor and major to get the final trait, even though it should be showing an arcane is needed. As soon as you back out of the troop and go back, the visual glitch will be fixed. I’m not sure if this is only visual and it actually takes the proper runestones, or if it’s only taking the runestones you see on the screen - if the latter this is an exploit. Either way this needs to be addressed."

I encountered this exact issue yesterday. Opponent had 3 troops left (somebody in 2nd slot, Alastair in 3rd and someone else in 4th). Alastair cast to give himself barrier. I used Atlanta, which should have damaged the 2 slot, broken the barrier on Alastair and damaged the 4th slot. The result was no damage to troop in 2 slot, break barrier on Alastair, and damage last troop. I’m on PS4 and this was after the patch.

1 Like

@VegaDark541

Have you personally retested those bugs to see if they reappear?

Not all of the bug fixes were on the list because they were so many.

@TaliaParks

I have not re-tested any of the bugs. I am aware that the patch notes said that there were more bugs fixed than were revealed. But, there’s quite a few, several of which are impractical to re-test. Also, re-testing them is pointless as the devs will know whether they patched these issues or not. If they did, they can just ignore them and post here what have been resolved or not. I think it should be a safe practice to re-post bugs without re-testing that they still exist so long as there’s be no feedback as to if that bug has been fixed or not.

There are also bugs they said they fixed but are still present. That’s why we retest bug fixes over and over, because sometimes they are deeper in the code and/or will only show under specific circumstances.

He’s not the only one when this disappearing gems bug occurred to me. That player I encountered had a different name and race: DS****70 at rank 200+

@Nimhain is correct to state[quote=“Nimhain, post:1, topic:11171”]
Rare case where gems don’t appear on the board when fighting certain players
[/quote]

I’m glad the earth mastery for hero has been fixed.

Arena though has a new bug whereby the enemy hero at hard difficulty has plus 1 health and plus 1 armor. The rest of the monsters had no boost to their stats like they’re suppose to for that difficulty.

If anything, and in my humble opinion, when it comes to Arena, those monster stats from Warlord 1 to 4 should apply for both teams. I never understood why its normal to stack against the human player since we are stuck with the same team for 8 or more rounds. The computer player has the freedom to choose from a big pool of certain heroes whose troops are considerably stronger than yours as it is. So why pile on? Why not level the playing field instead? Boost my allies’s monster stats when playing at harder difficulty levels; Boost my hero’s if its okay to boost the enemy hero’s stats as well.

Boosting monster stats for enemy troops is fine with questing, challenges, and PvP. At least the human player can freely choose which team to fight against those opponents with monster stats. Traits, bonuses, and ascension are factored in there unlike in Arena. What gives? :head_bandage:

1 Like

Come on game devs…
Get with the program(ming)
=P

Although pvp has been disappointing after the update, I’ve been doing my best to put together a team suited against unfair odds. I’ve been battling against players twice my levels and finally pulled off a few wins.

It resulted in this message.

I think your confusing correlation with causality.

Just curious, what level are you?

That has happened to me now and then over the last few months, usually when the servers are having trouble. Just wait a few seconds and try again.

Treasure Hunt just crashed when starting the game. Server issues again?

Two new bugs to report:

  1. Immortal King ressurection didn’t prevent the match from ending:

https://account.xbox.com/en-us/gameclip/92d1b0f1-f3b3-49b5-b538-7ef41446d314?gamerTag=VegaDark541&scid=ed190100-58a8-4dd8-8019-8e8323a144b4

  1. Number of Behomoths I have is showing x1 on the main screen, but x2 when I actually go into the troop:

https://account.xbox.com/en-us/gameclip/3335a7a0-0449-4156-a5e0-807b60cd0aaa?gamerTag=VegaDark541&scid=ed190100-58a8-4dd8-8019-8e8323a144b4

In addition this bug extends to ALL troops with summon upon death Traits. Ie upon death 25% summon Ancient Horror.

The AI becomes next turns After 3er matches is that right? I thought only 4er and 5er CombOS can Do this…

I had a match extend yesterday when I killed a 4th Gorgotha. It summoned an Ancient Horror and the match ended when I killed it.
That particular match had all 4 Gorgothas summon on death, so I wondered if something was wrong with that trait, but subsequent results were more normal.